Blocked nextcloud

Ok, maybe your mirror has not been updated yet. But please use console for now, ignore this message you get.

OK, I will wait. I the meantime, I cannot access my NC. But that’s not so important.
What is the present version of NC within NS?


Thank you all!

Do you have the latest version of the packages?

# rpm -q nextcloud nethserver-nextcloud

Yes I do, same as you

This could be due to a partial upgrade. Logs shall provide some clues. By running occ upgrade command you’ll either finish the upgrade or get some errors showing the problem:

sudo -u apache scl enable rh-php71 -- php -dmemory_limit=512M /usr/share/nextcloud/occ upgrade

Thanks a lot, that solved the situation!

In fact, sync works again, but I cannot get the web interface

I have HTTP ERROR 500

Did you spot any error in the logs or the command line? Related to an app?
Is the httpd service running?

No error while updating, httpd is active and running.
Where is the NC log file?

IIRC it’s under /var/lib/nethserver/nextcloud/ directory

Nothing special in the log. I keep on searching.
Thank you

Yoy can try to disable nextcloud apps or take a look in browser console for any clue

@loic You edited the headline to solved. Would you say us, what was your solution and mark this answer please as solution.

How can I disable NC? I have no access to its interface

I you mean to disable nextcloud apps, it can be done with the occ command. If other logs (nextcloud.log, /var/log/messages) didn’t provide any clue, check also httpd webserver logs.

After checking the logs of NC, I found some errors with the app carnet. I uninstalled it with the console and, tada, my web interface is back!
Be careful using carnet!

1 Like

A VM test environment is always a good idea before rolling your wishes out to a production environment. Glad you found your issue.