Blocked nextcloud

NethServer Version: 7.6.1810
Module: nethserver-nextcloud

For a few days, my Nextcloud module was blocked in maintenance mode. I could solve it thanks to this post:
But it now remains blocked aiming at upgrading to 15.0.5.
Is there any way to finalize this upgrade or cancel it?
Thanks for your help!

Please explain more detail of the process that you actually did.

I don’t remember having done anything, just usual updates through the nethserver interface.
I have just logged in as Nextcloud admin a few days ago to install a new application, Carnet.

Did you try to upgrade NC from within NC because it said there is an update, or did you update via console or software center?

When I saw I could not access Nextcloud any more, I tried to log in in the web interface, and I got this maintenance message. I cleared it thanks to the post in reference, but i am now stuck in a request for update to 15.0.5

I guess that request is within NC itself. Please do not follow that advice. Use the software center or enforce via the console: yum update nethserver-nextcloud

I usually only update through the Software Center. I hope I did nothing wrong while I was logged as admin.

I get “No packages marked for update” but I still get this upgrade message:

Ok, maybe your mirror has not been updated yet. But please use console for now, ignore this message you get.

OK, I will wait. I the meantime, I cannot access my NC. But that’s not so important.
What is the present version of NC within NS?


Thank you all!

Do you have the latest version of the packages?

# rpm -q nextcloud nethserver-nextcloud

Yes I do, same as you

This could be due to a partial upgrade. Logs shall provide some clues. By running occ upgrade command you’ll either finish the upgrade or get some errors showing the problem:

sudo -u apache scl enable rh-php71 -- php -dmemory_limit=512M /usr/share/nextcloud/occ upgrade

Thanks a lot, that solved the situation!

In fact, sync works again, but I cannot get the web interface

I have HTTP ERROR 500

Did you spot any error in the logs or the command line? Related to an app?
Is the httpd service running?

No error while updating, httpd is active and running.
Where is the NC log file?