Block Range of IPs from Internet


(Lewis) #1

Hi all, I am new here and to Nethserver, I have been using ClearOS as my Gateway/Firewall but heard about Nethserver and want to give it a try. How would I block a certain number of IPs on my lan from accessing the internet.


(Alessio Fattorini) #2

Hei Lewis welcome here!
what do you think about a firewall rule which blocks your IPs?
Give a look at this:
http://docs.nethserver.org/en/latest/firewall.html?highlight=firewall
If you can do it, share a screenshot so we can make a new FAQ

Edit: firstly, check you have Firewall module installed


(Lewis) #3

Thank you Alefattorini, I looked at the Dashboard > Firewall/Gateway. I cannot make sense of it, if i was looking to block IP’s from 192.168.1.81 - 254 where would I have to put that rule…


(Alessio Fattorini) #4

On firewall objects, you need to create a new IP range and then a new rule with such range/object as source


(Lewis) #5

Ok… Done, how does it look?


(Alessio Fattorini) #6

looks good, apply changes! Does it work? :slight_smile:


(Lewis) #7

I will update, I have to remove the ClearOS box first before I implement the NethSerevr… I at the moment I am doing all the settings before going life…
I am getting this error when trying to run LigthSquid; Error : report folder ‘/var/lightsquid’ not contain any valid data! Please run lightparser.pl (and check ‘report’ folder content) I have looked in the config file and tried changing squidlogpath = 1; Or is this because I have not configured the Red (eth1 WAN)


Error when trying to run LigthSquid
(Alessio Fattorini) #8

Ok, please don’t divert a topic by changing it midstream:


opening a new topic for a new issue, I already made it in your place:

and check the correct answer if you think it’s solved


(Lewis) #9

ok… sorry!!! That is what you get from newbies…lol


(Alessio Fattorini) #10

Don’t worry be happy :smile_cat: