Backup on Windows mount

NethServer Version: 7RC
Module: Backup
Hi,
we have a Windows 2008 R2 as DomainController and FileServer with DFS-Shares.
Also we have a Nethserver for sogo in the same IPAdress-Range but with an own domain. If I try to backup data of NS to a windows share it fails

Nov 24
01:00:17 groupware esmith::event[12987]: Unrecognized escape \I passed through
in regex; marked by <-- HERE in m//192.168.46.10(.*)/\MyWinDomain\I <–
HERE T\Backup/ at /usr/share/perl5/vendor_perl/NethServer/Backup.pm line 340,
line 1.

Nov 24
01:00:17 groupware kernel: Status code returned 0xc000006d
NT_STATUS_LOGON_FAILURE

I tried to mount the share in the terminal, but it’s error 22

mount -t cifs -o username=administrator@MyWinDomain.lokal.mywin-domain.de.de,password=MyPassword,sec=ntlm //192.168.46.10/MyWinDomain/IT/Backup /media/Backup

Output is:

mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Can somebody help me.

That’s the problem, the \ in your path
\MyWindDomain…\

Replace it with /

2 Likes

This is my working setup

1 Like

Thanks for your reply. I’ll try it.
Is there a chance to backup now, without changing the time to backup?

Just
backup-data

2 Likes

Ok, I get a permission denied

mount error(13): Permission denied

I think my problem is the domain. What is the username? I tried win-username@win-domainname, win-domainname\win-username and win-domainname/win-username. Also I tried with the NetBIOS DomainName.

If I try without the domain the error message is the following:

Retrying with upper case share name mount error(6): No such device or address

Try removing the first \ in the share path:

It should be MyWinDomain\Backup and not \MyWinDomain\Backup

I have found a note on my company wiki:

Try to change the ip of the target server with it’s hostname

If the hostname of the target server isn’t resolved put the association ip -> hostname in DNS Panel -> Hosts tab

Hi, thanks for your answer, but I can’t fix it. I tried the fqdn instead of the IP (ping fqdn is ok), I tried to write the share-adress without the first Backslash and I tried the share with slashes, of course without the first slash. I also tried to reach it without the folder backup. The “real” share for this is it$. The DFS is MyWinDomain/IT.

I’ve tried an other share with all rights for everybody too, same issue.

hi @m.traeumner

I installed a nethserver 7.2 RC1 for testing.
I have a similar problem. Trying to make a backup on a PC, if you use a domain user, it does not work: Access is denied.
I tried: DOMAIN\USER USER@DOMAIN

I created a local user of the PC.
To make it work I had to specify the user name as from image

syntax: username,domain=pc_name (because the user is local to the PC and not the domain)
@dev_team Is a bug? something has changed? I’m wrong?

2 Likes

Thanks for your testing.
With username,domain=domainname it works for me with a local user and also with a domainuser.
Did you test it with username,domain=domainname for a domain-user too?

1 Like

Hi @m.traeumner
I just ran the test by saving on my pc using a domain user and it seems to work. :grinning:

2 Likes

Thanks for your reply and your testing, I’ve marked this thread as solved.
But what do you think about a short documentation how to make settings for backup at the webinterface. I can’t find anything about it.

2 Likes

2 Years later I tried to test something and found my error at my manual mount.

It was the wrong destination folder, it had to be:

//192.168.46.10/Backup