Backup on cifs share

v7
backup

(Luca Aguzzoli) #1

Hello to everyone, I have a fresh install of nethserver 7 on which I would like to activate backup of CIFS share data, in my case a share on a Windows 7 pc.
pc windows 7 (ip 10.0.5.10) with c:\temp share
user:BACKUP
password: PASSWORD
in the security label

From other networked PCs, sharing is reachable with user and password just created.

on Nethserver Backup data side:
SERVER: 10.0.5.10
SHARE: temp
user: BACKUP
password: PASSWORD

the backup fails and the email message is as follows:

Extract from log file /var/log/backup-data.log:

2017-09-12 09:33:02 - START - Backup data started

2017-09-12 09:33:03 - ERROR - Error while mounting 10.0.5.10: mount error (12): Can not allocate memory Refer to the mount.cifs (8) manual page (eg man mount.cifs)

2017-09-12 09:33:03 - ERROR - Event pre-backup-data failed - 1

Same problem even with Nethserver 6.9, obviously wrong configuration.
Any help will be appreciated!!!

thanks and good day to everyone.

Luca


(Michael Träumner) #2

Hi Luca,
welcome to our community.
Please try to mount your cifs at terminal, perhaps at this point you get some more information about the error.
For instructions and some help you can have a look at this thread.

Michael


(Luca Aguzzoli) #3

Hi Michael, i tried as follow:
mount -t cifs //10.0.5.10/temp/ /mnt/pippo/ -o username=backup,password=backup
with the same error:
mount error(12): Cannot allocate memory

this is the configuration on web interface:

user=backup
password=backup


(Filippo Carletti) #4

Found this: https://www.linuxquestions.org/questions/linux-server-73/mount-cifs-cannot-allocate-memory-or-remote-i-o-error-after-data-transfer-4175508385/


(Luca Aguzzoli) #5

You are the man Filippo!!
It works great!
thank you very much!!

Luca