Assistance with understanding how ejabberd ssl cert is applied and Webtop Chat App and using my HAproxy instead for SSL

Hello Forum,

I’m hoping the @support_team and/or the @webtop_team @lucag can help me figure this out.

I’ve successfully setup ejabberd on my Nethserver and my Webtop mail uses WebChat from the local ejabberd.

I’ve added my wildcard cert ejabberd.pem file to the location /etc/ejabberd/
I’ve followed the documentation on integrating Webtop with ejabberd - https://docs.nethserver.org/en/v7/webtop5.html#chat-integration

I have an HAProxy Server setup in my network where I’m using my wildcard SSL cert. I can add a section to my HAProxy config for ejabberd running on Nethserver. But if I did this, where within WebTop can I point to my HAPorxy server to pickup my SSL cert? Is there a property I can add to Webtop Administration to point to my HAproxy server?

Thank you.

Hi Charles,
by default on WebTop the XMPP server in localhost is used.
You can change the default setting indicating which host and port to use by adding these global settings for the Core service in the admin panel: https://www.sonicle.com/docs/webtop5/core.html#xmpp-settings

Personally I never got to use them :wink:

1 Like

Hello @lucag,

Followup question for you. ejabberd works perfectly for us in Webtop. What are the settings Webptop uses to connect to the Nethserver ejabberd? Specifially I’m looking for the following detals Webtop uses Webtop uses the chat app:

XMPP/Jabber server URL
MUC server (if any is used)
Jabber ID (what is the login ID you use to login to ejabberd from Webtop Chat)
Channel (Does Webtop Chat connect to an ejabberd channel and if so what is the channel name).

Any advice you can give me or if there are config settings Webtop saves the above in I’d like to see these.

Thank you,

Charles.

Hi Charles,

I can add that WebTop, to connect to the ejabberd server, uses the username (complete domain) with which you are logged in.
You can also find more details in the ejabberd log (/var/log/ejabberd/ejabberd.log) :wink:

They are the ones configured in the settings that I had already linked to you: https://www.sonicle.com/docs/webtop5/core.html#xmpp-settings

Client side multiple channels are not supported

1 Like

Hello @lucag, I’m going to bring in @mrmarkuz into this conversation as well as I have opened another post related to connecting Nextcloud Talk (using matterbridge) to ejabberd. The other thread is found here:

What I’m attempting to do is to connect Nextcloud Talk and Webtop Chat through ejabberd. Some of my office staff use Webtop Mail and enjoy using Webtop Chat. Other employees in our office do not use Webtop. I know I could ask all employees to just use Nextcloud Talk but I’m attempting to find a way to bridge Talk with Webtop Chat.

With regards to Webtop Chat which uses my Nethserver ejabberd, you mention that mulitple channels are not supported in Webtop Chat. This tells me that Webtop Chat is using one channel. Where can I find the name of this channel?

I want both my Nextcloud Talk and Webtop Chat to connect over the same channel so I won’t be settnig up multiple channels.

Any advice or suggestions anyone can suggest would be greatly appreciated.

Thank you.

Hello @lucag and @mrmarkuz,

I’m folloiwng up on my posts regarding how to connect Nextcloud Tak (through Matterbridge) to my Nethserver ejabberd so that my Nextcloud Talk can connect to my Webtop Chat app.

From what @lucag said about Webtop chat “Client side multiple channels are not supported”. So I take this to mean that one channel is supported for Webtop Chat. When I installed ejabberd in Nethserver and I connected Webtop Chat to ejabberd I did not create a channel. What is the name of the channel Webtop Chat uses?

If Webtop (or maybe it’s ejabbered) has already created a channel then I’m thinking I can use this channel name in Matterbridge? @mrmarkuz you mentioned to me the command I can use to create a channel (or room) in ejabberd. But can you confirm if when I install ejabberd a channel/room default name is already created and that’s what Webtop chat uses?

Thank you.

Hi Charles,

from the documentation the setting xmpp.muc.subdomain is by default = conference

Maybe on the ejabber server side, on Nethserver, something is missing to use the MUC :thinking:… sorry but I don’t know this part well :smirk:

Maybe @giacomo can learn more about the possibility of using the MUC on our ejabber implementation :wink:

BR

1 Like

MUC is already enabled in our ejabberd config, from /etc/ejabberd/ejabberd.yml

...
 mod_muc:
    access:
      - allow
    access_admin:
      - allow: admin
    access_create: muc_create
    access_persistent: muc_create
  mod_muc_admin: {}
...

Creation of MUC channels is a client job.

2 Likes

Hello @lucag and @giacomo,

Appreciate your input into my post. I’ll need some clarification here:

To re-iterate the point of my post… I’ve installted ejabberd, Webtop and Nextcloud on my Nethserver. I’m attempting to connect my Nextcloud Talk to my Webtop Chat using Nextcloud Matterbridge @mrmarkuz was kind enough to test out connecting Talk to ejabberd but he created a new Channel (where he also provided the code needed to create a new channel on Nethserver).

But @lucag has confirmed that Webtop Chat (using ejabberd) does not support multiple channels.

So what I need to confirm here are the following:

  1. What is the Channel name used in Webtop Chat?
  2. Is there a default channel name created when ejabbered is installed? In other words…how do I display the channels available for use in ejabberd? I’ve looked at the ejabberd Admin and I see no channels or groups.
  3. Where is the matterbridge config file saved too? I enter in the Matterbridge settings screen the details to connec to XMPP?Jabber. I’m assuming these settings are saved in perhaps a file someplace. Where are these settings saved on my Nethserver?

I think I’m close here because once I can figure out the Channel name used by Webtop Chat…I’ll be able to use the same Channel name in Nextcloud Talk (Matterbridge).

Is there not a config file I can look into or a command I can run to display the channel name used in ejabberd?

Thank you all for your input.

@support_team, @webtop_team

Hello All,

I’m continuing to investigate how to connect my Webtop Chat and my Nextcloud Talk both installed on Nethserver using ejabberd. My usecase is that I have some employees who have their Webtop mail opened all day and they may not be in Nextcloud. Other employees do not have access to mail but do have Nextcloud opened. I know I could suggest to employees to use mail in Nextcloud or to have Nextcloud opened all day for all employees, but I’m curious to see if it’s possible to connect Webtop mail to Nextcloud Talk. Perhaps this investigation will be useful for others on this forum as well one day.

I’m also wondering if this is the best place to continue this investigation or if a new thread should be created. My initial question for this post was to Webtop Team to understand how I can repoint my Webtop Chat to a proxy server.

On to my investigation…I’m hoping one of these support teams will be able to assist with expanding what I’ve found.

ejabberd/Nextcloud-matterbridge:

In order for Nextcloud Talk to connect to ejabberd I need to use a Channel. I’m assuming Channel also means room in ejabberd. I’ve logged into ejabberd Admin from Nethserver and I can see some details for my Webtop users who use Webtop chat. Nowhere in ejabberd Admin I find the channel or room my users are connected into. I do see a “multi-user chat” list for chatrooms but this page is empty. It appears that ejabberd when installed on Nethserver has no room created.

I then went to the command line and issued the following command to check on the rooms a user is connected into:

> # cd /opt/ejabberd-20.03/bin/
> # ./ejabberdctl  get_user_rooms user1@domain.local localhost

This resulted in no returned data. I didn’t get an error so I’m assuming the command was correct. And based on my investigation into the ejabberd admin page I don’t think any user is connected to a room. Is this a correct assumption?

Webtop:

Luca has already confirmed for me that multi user chatrooms do not work with Webtop Chat. So my question is what channel does Webtop Chat use for users to users to chat from? You mention that

xmpp.muc.subdomain is by default = conference

Is xmpp.muc.subdomain mean channel?

Marcus has provided for me the command I can use to create a room. If I do create my own room/channel for all employees to use…how do I update Webtop to connect to this room/channel?

Thank you.

Hi Charles,

what I meant is that the interface with which WebTop uses the chat does not provide the possibility for the user to change channel (the passage from one channel to another).

From the WebTop admin panel you can decide which default channel to use for the chat of all users (as I have already shown you), the default is conference :wink:
(muc = multi user channel)

Unfortunately I’m not that experienced on ejjaberd and I don’t know how else to help you, sorry :relieved:

BR

1 Like

Thank you @lucag for your patience with my questions. I’m a little slow on picking up on how this works so I do appreciate your input.

Now I think I understand what you mean. It would appear that a default channel called “conference” has already been created in ejabberd. I don’t understand why when I issue the ejabbered commands to check the channel or group name my employees are members of in ejabbered I don’t see a channel name of “conference”. But I’ll push forward…

I will test the following tonight:

  1. I will use the code that Marcus provided me to create a new channel.
  2. I will add to the Admin of Webtop a new xmpp.muc.subdomain property for the new channel name.

Question for Luca:
When I add this new property do I select the service of com.sonicle.webtop.core? Or is there another service I need to use when adding in the xmpp.muc.subdomain property?

Thank you.

1 Like

Access the admin panel and add this setting for the com.sonicle.webtop.core service with the key xmpp.muc.subdomain and the value of the new channel:

BR

1 Like