Applications: nTopNG-Link with wrong Port# assigned

When installing nTopNG, the wrong port is assigned (980 instead of 3000). Where can this be changed afterwards?
The same applies to the “Open” button on the right side.

The link is correct because the ntopng is also served using a virtualhost on port 980 with a random URL that protect the access. The process itself listens on port 3000 which is usually available only on green network.

Said that, we are going to expand ntopng integration. :wink:

3 Likes

The button “Open bandwidth monitor” which tries to connect to port 980 only gives an error message in my installation. Unter settings a link with port 3000 is shown and clicking on this link opens ntopng correctly.

BTW: I dont’ really understand, why Nethserver opens so many ports to the red interface. To the red interface all administration and statistic ports should be closed by default.

I agree with you, but many installations out there still have open to the public only port 980 (old Server Manager).
This is why @davide_marini forced us to keep the link on port 980 :wink:

What is the point in having new installations not working? They should work out of the box.

Please be kind. :slight_smile:
We are tying to improving it right now, but it’s not always to balance choice when you have more than 10K machines with automatic upgrades :wink:

Edit: https://github.com/NethServer/nethserver-suricata/pull/26

1 Like