After creating network bridge for virtual machine NS becomes unreachable

network
v7
webvirtmgr

(Armin) #1

NethServer Version: 7.4
Module: Network / Virtual machine

Goal: Reach virtual machine via LAN

way there: Create a network bridge in NS as described in the how to?!

issue: Every time I try that the NS becomes unreachable

There are many posts about that here but I seem to miss something. I try to follow this how to https://wiki.nethserver.org/doku.php?id=ns_webvirtmgr and this guy seemingly had the same issue Network and webvirtmgr but I can’t figure it out.

My NS has 192.168.1.27 so I do that:

imagen

and than that?

imagen

Or where am I wrong?

Thanks for any help!


(Saito Benkei) #2

Why you change the IP of green from 192.168.1.27 to 192.168.1.28?

Before you configure the bridge, the IP assigned to your lan is 192.168.1.27?

If you change the IP, your NS is now reachable at https://192.168.1.28:980


(Armin) #3

ok, that was one error!

I’ve tried like this just now:

imagen

The NS still became unreachable via the network and I had to reset the network config. Could there be a bug or am I doing something wrong?


(Markus Neuberger) #4

It looks like you already have a bridge and want to bridge the bridge interface.
If you already have a br0 interface you’re done and don’t need another bridge for the VMs in NethServer.


(Armin) #5

Yes, I think you are right. Then I miss something else here:

On my NS I have a virtual machine that hosts another NS to test stuff. I know little about it and this way when I make mistakes my NS is still up an running because I make the mistakes in the virtual machine first.

I have the NS in the virtual machine running. Now I don’t know how to access the apache, the Server Manager webpage of the NS on the virtual machine … . Seems like I am not getting the concept of a bridge. Can you tell me how to do that?

edit: Maybe my mistake was here at setting up the virtual machine:

I am looking into that now


(Markus Neuberger) #6

No, you don’t need another connection.

Networks should look like this:

grafik

Your VM Nethserver should be in the same network as your Host Nethserver as they share the bridged interface. If you use DHCP in your network or on your Host Nethserver, the VM NS will get an IP and you should be able to reach your VM Nethserver.


(Armin) #7

So my ‘network’ on the host NS looks like like that:

The IP is static and 192.168.1.27 is how i reach the Server Manager.

imagen


imagen

How can I access my VM NS now or assign it an IP?


(Markus Neuberger) #8

A VM is an instance. You may assign an IP during VM NS installation.

Create a new instance, use default network and access the console:


(Armin) #9

oh, yes! It works now! Something blocked my mind there. Thank you very much!