Active directory Problem

I have to create an active directory, but when I reach this (I attached the screenshot) which DC IP address should I insert?

I hope the support help me, I am new to nethserver


welcome to Nethserver Community.

It’s up to you as long as the IP is in the same subnet as your Nethserver and it is not used.

I prefer to use the next free IP after the Nethserver.

Nethserver has so I give to the container.


1 Like

So if I have I give right?

The you need to see if its a free ip on your dhcp server see with angryip to scan your network

Sorry but I don’t understand. Can you explain better?

angryip its a app that scans your network
with that you can see if it’s free to assign into your nethserver AD ip container

Ok. I did it, but it gives me error by the way

It seems you are not using an static IP address for the LAN (green) network interface.

How many network interfaces do you have/plan to use for NethServer? Only one for LAN (green) interface, or also a WAN (red) interface?
Is there a router/gateway in place? Which IP address does it has?

I’m using a static ip address on the lan network and I have only this,the Lan.
The ip address of nethserver is

Another problem

You can try to configure AD again (using an unassigned IP address) and see if it succeeds.
Before, if you want to, you can copy the command, paste it into the terminal and share the error result.

When choosing an IP address for the Samb4 AD container, make sure the IP address is not part of the DHCP scope.
If your DHCP scope is the whole green subnet, change the scope to something smaller so you have some IP addresses available outside the DHCP scope for static IP assignement.

You use subnet 192.168.1.x with a subnetmask of
You have your NethServer at IP and you have DHCP giving out addresses rranging from -
In this case all IP addresses in the subnet are within the DHCP scope.
change the DHCP scope to for example -
This way you have all IP addresses from - available for static assignment. So you avoid DHCP giving out addresses that are in use by a device with a static IP address.

1 Like

Blue_Diamond, note this is just an example. In your setup might be already taken by your router, which it is most probably also serving addresses through DHCP.

I tried but it gives me another problem

How can I fix?

Can Nethserver reach the Internet (ping external IP and external domain name)?

Yes ping works


yum clean all

and retry.

Tried, Same error

Is the server able to resolve