Active Directory machine password


can anybody tell how I find the password of the machine hosting the AD controller?
The command “account-provider-test dump” gives me “BindDN” : “DOMAIN\ADHOST$”. The “BindPassword” consists of unreadable hyroglyphs which do not work to bind with. I need to know this password or maybe need to change it.

Hi @rasi,

it’s in binary form now. See

You may use another AD user as workaround.

Tried this, but didn’t work…

/usr/bin/systemd-run -M nsdc -t /bin/bash
samba-tool user setpassword nsdc-testserver$

Please do not change the machine password, you will have problems for the join!

It’s for binding Horde to LDAP. If I use the Administrator or any other AD user, I get “DN of the user not found”.
I had a univention server before. There it worked fine with the machine bind. It my have to do with the fact, that the AD computers are on a different level in the LDAP tree.

I can confirm this, join not working anymore. Reinstalling nethserver-dc now…happy that it was just a testsystem.