Zabbix 5.0 LTS has been released

Hi guys,

thanks for the great work. I am looking forward to Andy’s hands on training and as prerequisite I installed zabbix from mrmarkuz repo on a new nethserver, which worked flawlessly. :+1:

I don’t see a possibility to switch the webinterface to german language though. Is there any additional package or configuration needed?

You may edit /usr/share/zabbix/include/locales.inc.php and edit line 57 to set “display” to true for German language:

'de_DE' => ['name' => _('German (de_DE)'), 'display' => true],

After browser refresh it should be available in the “User settings” dropdown. They hide it by default because it’s not fully translated.

(Source)

2 Likes

Perfect. Thank you, that worked. :slight_smile:

@mrmarkuz
@lucio3011

Hi Markus

I’m helping a friend who has a NethServer running at a lawyers practice.
The NethServer has a Crostino Subscription running.

My friend wanted to update Zabbix and ran into issues…

I had a good look, and completly deinstalled Zabbix:

yum remove zabbix* nethserver-zabbix

I then also removed the PG database, removed the entries in the cnfiguration DB, cleared out the folders under /var/lib/nethserver/zabbix, /var/lib/zabbix, /etc/zabbix

Even rebooted the server.

Doing an installation it breaks with

Note: It’s looking for Zabbix 4x stuff on a fresh installation of Zabbix 5x - and failing!

This shouldn’t happen - even with a subscription (Repo conflict?).

It seems more a deps problem on something…

Any ideas?

Thanks
Andy

Did you already try with enabling the repos?

yum -y install --enablerepo=mrmarkuz,zabbix,zabbix-frontend nethserver-zabbix

Maybe it helps to clean yum before reinstalling?

yum clean all

Both tried…

I almost always automatically enable the repos with a -y… :slight_smile:
Some habits die hard!

The console still has the command listed… :slight_smile:

Just to discard it, check if there’s and older zabbix repo file.

1 Like

Can you reach https://repo.zabbix.com/ ?

Curl can…

@dnutan

How / where do I check the repos?
AFAIK in /etc/yum.repos.d…

Correct. Check the zabbix repo and the URLs it contains

Looks actually good:

Just install most recent zabbix release:

yum -y install https://repo.zabbix.com/zabbix/5.0/rhel/7/x86_64/zabbix-release-5.0-1.el7.noarch.rpm

That is installed now…

However:

running the next step:

yum -y --enablerepo=mrmarkuz,zabbix,zabbix-frontend install nethserver-zabbix

gives me this:

The error seems to appear right after checking the deps…

And after a full repo cache cleanup?

yum clean all --enablerepo=*
2 Likes

@dnutan

Bingo!

That was the solution!
It’s installing the right versions right now!

:slight_smile:

I do love NethServer - especially the people on this Forum!

And It’s back up & running…

My 2 cents
Andy

3 Likes

Hi all,

What a marvellous forum this is.
A pro has a problem, another pro solves it within an hour.

Michel-André

7 Likes

And for No-Pros too. This is actually the even greater achievement, as it demands a lot more from the Pros.

3 Likes