Z-push - memory exhausted


I’m having the following error with z-push synchronization:

Fatal error: /usr/share/webtop/z-push/include/mimeDecode.php:477 - Allowed memory size of 134217728 bytes exhausted (tried to allocate 5756101 bytes) (1)

I’ve removed an e-mail which has 22.22MB and the synchronization is working again.

What’s the best way to address this situation? Increasing the memory limit, limit attachments size?

Other thing, should not WebTop show when was the last synchronization performed?

Setting --> WebTop --> Synchronization


You need to increase PHP memory limit.

I don’t know, @webtop_team any idea? I’m sure you can view it from command line using z-push tools.

Hi @Tiago,

You can see the list of devices synchronized with the z-push-admin tool in this way:

(List of devices)
/usr/share/webtop/z-push/z-push-admin.php -a list

(Last synchronization)
/usr/share/webtop/z-push/z-push-admin.php -a lastsync

From web interface: Settings -> Syncronisation -> select the device and click the “Detailed info” button



@lucag Now I see it.

But, shouldn’t the column "Last sync " of the Synchronization tab be filled with that info? Mine is empty.