Yum update fails

Hello there - any suggestions for what the course of action is here - i can see the options but dont understand the consequences of taking them - the same error occurs for other repositories also (yum update --enablerepo=danb35) so seems like an issue with my server

[root@cwprod10v01 ~]# yum update --enablerepo=stephdl
Loaded plugins: auto-update-debuginfo, changelog, fastestmirror,
: nethserver_events
Loading mirror speeds from cached hostfile


If above article doesn’t help to resolve this issue please use https://bugs.centos.org/.

https://u3.nethserver.com/stable/7.9.2009/base/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden
Trying other mirror.

One of the configured repositories failed (Stable mirror: CentOS Base 7),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=sb-base ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable sb-base
        subscription-manager repos --disable=sb-base

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice

        yum-config-manager --save --setopt=sb-base.skip_if_unavailable=true

failure: repodata/repomd.xml from sb-base: [Errno 256] No more mirrors to try.
https://u2.nethserver.com/stable/7.9.2009/base/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden
https://u3.nethserver.com/stable/7.9.2009/base/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden
[root@cwprod10v01 ~]#

If you have a subscription check if it has expired.


i think it has so i will renew now - the error doesnt mention a subscription which prompts me to ask; is the error related to no subscription or is obtaining an answer to the question dependent on having a subscription?!

IIRC the repos starting with sb- are from subscription servers, that’s why I asked about it.
So yes, problem seems related to no subscription (another clue is the update repo server replying with a Forbidden message)


Just to be clear, this is never the case–we here don’t (ordinarily) know if you have a subscription, and we’re happy to help regardless. But your problem appears to be caused by an expired subscription. Renewing the subscription should resolve it. If you don’t intend to renew it, there’s a way to configure your system to not use the subscription repos that we’d have to find.

appreciated - sorry i didnt mean for the comment to be that loaded, i just wasnt clear whats occuring … ive renewed subscription and will apply the stack of upgrades and try again! cheers for feedback