Yum update error on NethServer release 7.7.1908

NethServer release 7.7.1908 (final)
Kernel release 3.10.0-1062.4.1.el7.x86_64


yum update
Loaded plugins: changelog, fastestmirror, langpacks, nethserver_events
Loading mirror speeds from cached hostfile

  • nethserver-base: server.liftingtrade.hu
  • nethserver-updates: server.liftingtrade.hu
    Resolving Dependencies
    –> Running transaction check
    —> Package PackageKit.x86_64 0:1.1.10-1.el7.centos will be obsoleted
    –> Processing Dependency: PackageKit(x86-64) >= 0.5.0 for package: gnome-packagekit-common-3.28.0-1.el7.x86_64
    –> Processing Dependency: PackageKit(x86-64) >= 1.1.1 for package: gnome-software-3.28.2-3.el7.x86_64
    —> Package PackageKit-yum.x86_64 0:1.1.10-1.el7.centos will be obsoleted
    —> Package nethserver-cockpit.noarch 0:1.2.1-1.ns7 will be obsoleting
    –> Processing Dependency: perl(String::ShellQuote) for package: nethserver-cockpit-1.2.1-1.ns7.noarch
    –> Processing Dependency: perl(NethServer::BackupData) for package: nethserver-cockpit-1.2.1-1.ns7.noarch
    –> Processing Dependency: nethserver-lang-cockpit for package: nethserver-cockpit-1.2.1-1.ns7.noarch
    –> Processing Dependency: expect for package: nethserver-cockpit-1.2.1-1.ns7.noarch
    –> Processing Dependency: cockpit-storaged for package: nethserver-cockpit-1.2.1-1.ns7.noarch
    –> Processing Dependency: cockpit for package: nethserver-cockpit-1.2.1-1.ns7.noarch
    —> Package nethserver-cockpit-lib.noarch 0:1.2.0-1.ns7 will be updated
    —> Package nethserver-cockpit-lib.noarch 0:1.2.1-1.ns7 will be an update
    –> Running transaction check
    —> Package PackageKit.x86_64 0:1.1.10-1.el7.centos will be obsoleted
    –> Processing Dependency: PackageKit(x86-64) >= 0.5.0 for package: gnome-packagekit-common-3.28.0-1.el7.x86_64
    –> Processing Dependency: PackageKit(x86-64) >= 1.1.1 for package: gnome-software-3.28.2-3.el7.x86_64
    —> Package cockpit.x86_64 0:195.1-1.el7.centos.0.1 will be installed
    –> Processing Dependency: cockpit-ws for package: cockpit-195.1-1.el7.centos.0.1.x86_64
    –> Processing Dependency: cockpit-system for package: cockpit-195.1-1.el7.centos.0.1.x86_64
    –> Processing Dependency: cockpit-bridge for package: cockpit-195.1-1.el7.centos.0.1.x86_64
    —> Package cockpit-storaged.noarch 0:195.1-1.el7.centos.0.1 will be installed
    –> Processing Dependency: udisks2-lvm2 >= 2.6 for package: cockpit-storaged-195.1-1.el7.centos.0.1.noarch
    –> Processing Dependency: udisks2-iscsi >= 2.6 for package: cockpit-storaged-195.1-1.el7.centos.0.1.noarch
    —> Package expect.x86_64 0:5.45-14.el7_1 will be installed
    –> Processing Dependency: libtcl8.5.so()(64bit) for package: expect-5.45-14.el7_1.x86_64
    —> Package nethserver-backup-data.noarch 0:1.6.4-1.ns7 will be installed
    –> Processing Dependency: perl(NethServer::BackupConfig) for package: nethserver-backup-data-1.6.4-1.ns7.noarch
    –> Processing Dependency: perl(NethServer::Backup) for package: nethserver-backup-data-1.6.4-1.ns7.noarch
    –> Processing Dependency: nethserver-backup-config for package: nethserver-backup-data-1.6.4-1.ns7.noarch
    —> Package nethserver-lang-cockpit.noarch 0:1.4.2-2.ns7 will be installed
    —> Package perl-String-ShellQuote.noarch 0:1.04-10.el7 will be installed
    –> Running transaction check
    —> Package PackageKit.x86_64 0:1.1.10-1.el7.centos will be obsoleted
    –> Processing Dependency: PackageKit(x86-64) >= 0.5.0 for package: gnome-packagekit-common-3.28.0-1.el7.x86_64
    –> Processing Dependency: PackageKit(x86-64) >= 1.1.1 for package: gnome-software-3.28.2-3.el7.x86_64
    —> Package cockpit-bridge.x86_64 0:195.1-1.el7.centos.0.1 will be installed
    —> Package cockpit-system.noarch 0:195.1-1.el7.centos.0.1 will be installed
    —> Package cockpit-ws.x86_64 0:195.1-1.el7.centos.0.1 will be installed
    —> Package nethserver-backup-config.noarch 0:2.4.0-1.ns7 will be installed
    —> Package tcl.x86_64 1:8.5.13-8.el7 will be installed
    —> Package udisks2-iscsi.x86_64 0:2.7.3-9.el7 will be installed
    —> Package udisks2-lvm2.x86_64 0:2.7.3-9.el7 will be installed
    –> Processing Dependency: libblockdev-lvm >= 2.13 for package: udisks2-lvm2-2.7.3-9.el7.x86_64
    –> Running transaction check
    —> Package PackageKit.x86_64 0:1.1.10-1.el7.centos will be obsoleted
    –> Processing Dependency: PackageKit(x86-64) >= 0.5.0 for package: gnome-packagekit-common-3.28.0-1.el7.x86_64
    –> Processing Dependency: PackageKit(x86-64) >= 1.1.1 for package: gnome-software-3.28.2-3.el7.x86_64
    —> Package libblockdev-lvm.x86_64 0:2.18-4.el7 will be installed
    –> Finished Dependency Resolution
    Error: Package: gnome-packagekit-common-3.28.0-1.el7.x86_64 (@base)
    Requires: PackageKit(x86-64) >= 0.5.0
    Removing: PackageKit-1.1.10-1.el7.centos.x86_64 (@base)
    PackageKit(x86-64) = 1.1.10-1.el7.centos
    Obsoleted By: nethserver-cockpit-1.2.1-1.ns7.noarch (nethserver-updates)
    Not found
    Error: Package: gnome-software-3.28.2-3.el7.x86_64 (@base)
    Requires: PackageKit(x86-64) >= 1.1.1
    Removing: PackageKit-1.1.10-1.el7.centos.x86_64 (@base)
    PackageKit(x86-64) = 1.1.10-1.el7.centos
    Obsoleted By: nethserver-cockpit-1.2.1-1.ns7.noarch (nethserver-updates)
    Not found
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

gnome-software-3.28.2-3.el7.x86_64 don’t think is required from NethServer…

1 Like