Yum downloads - md5 error

yum
updates
v7

(Eddie Atherton) #1

NethServer Version: 7.5
Module: yum

Been getting the following error for the last couple of days from the cron yum download:

/etc/cron.daily/0yum-daily.cron:

/var/cache/yum/x86_64/7/sb-nethserver-updates/packages/nethserver-collectd-3.0.6-1.ns7_3.0.7-1.ns7.noarch.drpm.6005.tmp: md5 mismatch of result
Some delta RPMs failed to download or rebuild. Retrying..

I thought after the first time it was just a download glitch and the next attempt would fix it, but it doesn’t appear to have.

The package is still listed as available to update:

The following updates will be downloaded on Nethserver.BogoLinux.net:
================================================================================
 Package                      Arch   Version        Repository             Size
================================================================================
Updating:
 certbot                      noarch 0.25.1-3.el7   sb-epel                21 k
 gnupg2                       x86_64 2.0.22-5.el7_5 sb-updates            1.5 M
 nethserver-base              noarch 3.4.1-1.ns7    sb-nethserver-updates 242 k
 nethserver-collectd          noarch 3.0.7-1.ns7    sb-nethserver-updates  23 k
 nethserver-httpd             noarch 3.2.6-1.ns7    sb-nethserver-updates  53 k
 nethserver-httpd-virtualhosts
                              noarch 3.2.6-1.ns7    sb-nethserver-updates  39 k
 nethserver-lib               noarch 2.2.8-1.ns7    sb-nethserver-updates  98 k
 python                       x86_64 2.7.5-69.el7_5 sb-updates             93 k
 python-libs                  x86_64 2.7.5-69.el7_5 sb-updates            5.6 M
 python2-certbot              noarch 0.25.1-3.el7   sb-epel               503 k

Transaction Summary
================================================================================
Upgrade  10 Packages
Updates downloaded successfully.

Hmmmm. That last line seems to contradict the other e-mail.

Cheers.


(Davide Principi) #2

It’s strange for sure. IIRC if delta rebuild fails the complete package is downloaded anyway.

It looks like your updates aren’t applied automatically. Can you install 3.0.7 correctly?


(Eddie Atherton) #3

Correct, I just have it set to download them.

I haven’t tried yet, but I don’t see why not, based on the cache seems to have full rpms, not the deltas (see below).

That looks to be the case:

[root@Nethserver ~]# ls -l /var/cache/yum/x86_64/7/sb-nethserver-updates/packages/
total 464
-rw-r--r-- 1 root root 248252 Jul 13 03:05 nethserver-base-3.4.1-1.ns7.noarch.rpm
-rw-r--r-- 1 root root  23608 Jul 12 06:05 nethserver-collectd-3.0.7-1.ns7.noarch.rpm
-rw-r--r-- 1 root root  53776 Jul 12 03:24 nethserver-httpd-3.2.6-1.ns7.noarch.rpm
-rw-r--r-- 1 root root  40224 Jul 12 03:24 nethserver-httpd-virtualhosts-3.2.6-1.ns7.noarch.rpm
-rw-r--r-- 1 root root 100104 Jul 26 04:49 nethserver-lib-2.2.8-1.ns7.noarch.rpm
[root@Nethserver ~]#

But then, shouldn’t that have happened on the first day, and on the second just report what’s ready to be installed. Why would it try to download the delta again.

Cheers.