"Your connection is not private"

webproxy
v7

(Antonio Carlos Lemos Junior) #1

NethServer Version: 7.5.1804 (final)
Module: Proxy Server

Hello people. I’m getting the following message “Your connection to this site is not private” in Edge, Chrome, and Opera browsers. In firefox I am able to navigate normally. I am using the authenticated proxy module having windows XP and 10 as client. The date and time in Nethserver and Windows are correct. Any tips for resolving this situation? Thanks


(Markus Neuberger) #2

On any site?

What does the certificate show when you get the error?

Are there errors in the logfiles /var/log/squid/access.log or /var/log/squid/cache.log?

Just an idea: Firefox may have special proxy settings whereas the others use the proxy settings in Windows internet settings.


(Antonio Carlos Lemos Junior) #3

Hi @mrmarkuz,

Thanks again.

On any site?

yes, any site.

What does the certificate show when you get the error?

No certificate error.

Are there errors in the logfiles /var/log/squid/access.log or /var/log/squid/cache.log?

Attached.

Just an idea: Firefox may have special proxy settings whereas the others use the proxy settings in Windows internet settings.

Yes, the problem is in all that use the windows proxy settings.


(Markus Neuberger) #4

Usually you should see which user connects but in your access.log you only see IP adresses.

Do you use the FQDN like proxy.domain.local in the internet settings?

grafik

It’s always a good idea to restart the browsers when testing new proxy settings.


(Antonio Carlos Lemos Junior) #5

Thanks a lot @mrmarkuz.

Worked like a charm.


(Antonio Carlos Lemos Junior) #6

@mrmarkuz is it possible to automatically force the client to use the FQDN ?


(Markus Neuberger) #7

For Windows clients it’s possible via Active Directory Group Policies: In AD you may create/edit a group policy for your domain and force a specific proxy and use FQDN. Editing group policy is possible with samba AD too, just use group policy editor on a domain joined Windows client. I did a quick test on Windows 10 and it didn’t work for Edge but other things do work this way so maybe I used some wrong policy.

https://social.technet.microsoft.com/wiki/contents/articles/5156.how-to-force-proxy-settings-via-group-policy.aspx

Another way is to edit registry maybe with a script, just an idea.

https://support.microsoft.com/en-za/help/819961/how-to-configure-client-proxy-server-settings-by-using-a-registry-file


(Antonio Carlos Lemos Junior) #8

Ok. I’ll take a look.
Thanks a lot.