Xabber for Server CHAT

Hi all, first question …
I’m trying Nethserver 7 RC3 in its various parts.
“Server Chat”: I activated the flag, and I tried with two PCs with pedgin software, all OK.
I tried XABBER for Android but does’t work. Is there anyone who has tried it and had successful.
There is a guide on how to configure XABBER?
Thank you

In Italiano casomai non si capisse, visto il mio inglese…

Salve a tutti, prima domanda…
Sto provando Nethserver nelle sue varie parti. “Server Chat”: ho attivato il flag e ho provato con due Pc con il software pedgin, tutto OK. Ho provato XABBER per Android ma non funziona. C’è qualcuno che ha provato e cè riuscito. C’è una guida su come configurare XABBER?

Hi @roberto.schiano :wave:

I also had problems with xabber. I tried with beta verision and it worked immediately.

I think the problem is related to the certificate (the standard version does not require acceptance, beta)

1 Like

I don’t understand the solution.
Yuo talk about of beta, beta of Nethserver? But the rc3 is later than the beta?

I think it refers to xabber beta.

1 Like

yes, try xabber beta. it works.

Here is how to configure Xabber Beta for Android in Nethserver NG 6.8 - maybe it works in NG 7 also…

I have Xabber Beta in italian so I will try to translate the steps in english…

Create a new account:

Tap on hamburger (the three orizontal lines icon on the top-left corner) -> select “XMPP Account” (Account XMPP)
click on the “+” icon in the top-right corner

Username (nome utente): username@domain.tld

Password: YourPassword

Save Password (Memorizza password): checked
Other options: unchecked

Tap on “Add Account” (Aggiungi Account) on top-right corner

You will have a “error connection”: don’t worry!

In the new option list that you have visualized:

Personalized host (Host personalizzato): checked

Host: host.domain.tld

Port (porta): 5222

Clcik on the arrow on the top-left corner

Voila’: you have your account online

Maybe it will ask you for the certificate: accept the certificate


@saitobenkei good notes! thanks for sharing it, hope that @roberto.schiano tests them out

Hello everyone…
I tried but unfortunately does not work.
I’m trying to Neth rc3 version 7, I installed XABBER beta (1.0.74).
I created the user roberto@fanscomputer.local, I entered my password, I left the server field blank and I put a fleg of custom settings.
I tried with the server name (neth.fanscomputer.local) and the IP (
I tried with priority 0 or 10, I tried Enable TLS and Require TLS.
I tried using compression yes and no.
After all these tests always get a connection error. I repeat with pedgin the server works.
Other suggestions?
thank you

Your smartphone/tablet resolves the neth.fanscomputer.local as
If you open a browser in your smartphone and digit http://neth.fanscomputer.local , you see the welcome page of the nethserver?

1 Like

I just tried with Nethserver 7rc3 with openLDAP as authenticator and Xabber Beta for Android v1.0.74.

With the configuration steps in my previous post it works.

Check if the smartphone/tablet resolves the hostname.

1 Like

yes, if I browse get the neth page, and whit 980, enter in server configuration
I’ll try to disable everything and repeat the intallation, then enclose the contents of the log file

Please, try with http://neth.fanscomputer.local (or the FQDN of your server) and not the

You should see the welcome page of the server. If you don’t see it, It should be a DNS problem of the smartphone/tablet.

Maybe the smartphone/tablet is connected on the lan via the WiFi of the ADSL Router with it’s own dhcp server?

1 Like

In fact typing http: //neth.fanscomputer.local I don’t access the web page, but only using the IP address (
My Neth server has static IP address and DHCP service is provided by another network server …

Hi @roberto.schiano
Do you have a DNS server (configurable) in the network?


Check if you can add a entry to your DNS server for your host neth.fanscomputer.local that points to the IP address

Check if the smartphone/tablet uses that DHCP/DNS server to retrieve the configuration IP

If other PCs of the network use that DHCP/DNS server check from one of those that the resolution name works:

Open a command prompt in administrative mode then digit:

ipconfig /flushdns
ping neth.fanscomputer.local

You should see the answer from

Now I can’t. Next days I’ll test and I tell you.

1 Like