Wrong time from NTP

v7

(David Gordon) #1

My Date and Time is wrong! I tried reading this NTP Troubles, no time synchronization thread but some of the commands don’t work for me.
The time on my NethServer is wrong and keeps going wrong. I want to use NTP but it seems I can’t ping pool.ntp.org, I get 80% packet loss. I’ve changed the NTP server to time.euro.apple.com but I think the time is still drifting.

I tried

[root@neth ~]# config show | grep ntp
    NTPServer=pool.ntp.org
[root@neth ~]# service ntpd status
Redirecting to /bin/systemctl status ntpd.service
Unit ntpd.service could not be found.
[root@neth ~]# ntpdate -u -d pool.ntp.org
-bash: ntpdate: command not found

So I entered the Apple tome server but my Dashboard still shows the wrong time (currently 10:55 when its really 11:04).

Any clues?!


(Rob Bosch) #2

Looks like the ntpd service didn’t start. Can you start it manually and do an update?


(David Gordon) #3

I’m failing to find the command to do that, what should I be using?

[root@neth ~]# service ntpd restart
Redirecting to /bin/systemctl restart ntpd.service
Failed to restart ntpd.service: Unit not found.


(Rob Bosch) #4

No NTP service installed? Weird!
@giacomo? any suggestions?


(David Gordon) #5

I do appear to have chronyd, if that makes any difference…

chronyd (Network Time Protocol) Enabled Running UDP: 123


(Giacomo Sanchietti) #6

Since CentOS 7, ntpd has been deprecated in favor of chronyd.

To force time sync:

systemctl restart chronyd

See also man chronyc


(David Gordon) #7

I can force a time sync but later (at 16:22) I get this result…

Well, at least the day is correct!

[root@neth ~]# chronyc tracking
Reference ID    : 11FD22FD (ntp.euro.apple.com)
Stratum         : 2
Ref time (UTC)  : Wed Jun 27 14:56:02 2018
System time     : 0.000000004 seconds slow of NTP time
Last offset     : -13801.641601562 seconds
RMS offset      : 13801.641601562 seconds
Frequency       : 62.931 ppm fast
Residual freq   : -3843248.500 ppm
Skew            : 433.289 ppm
Root delay      : 0.017012775 seconds
Root dispersion : 1513.206542969 seconds
Update interval : 0.0 seconds
Leap status     : Normal