Wrong domain address for sender

Ok, ive looked around and i have probably missed it but i have setup Nethserver connected to active directory and synchronised all accounts, the ad domain is something.local and i have setup alias domains in the email.

the problem im having is when sending emails through outlook (Activesync) the users are defaulting to .local and the receiving email server is rejecting it.

i am using Sogo and i cant see how to change it to one of the alias



Outlook… mobile or desktop (Windows/MacOS software)?

Windows outlook, desktop software though the same applies using Sogo

The receiving email sees the .domain.local and rejects it

Disclaimer: everything comes after this is only my personal opinion. I am not part of the project, only a long time user.

AFAIK… ActiveSync is intended for mobile devices (like integrated iOS calendar and address book support).
If you would like to sync “whole things”…
IMAP for email management (hoping you can configure specific folders for sent, trash, draft and spam with IMAP)
a CardDAV + CalDAV syncronizer for Address book and calendar entries.

In this way, you should be able to have most of functionalities you need.

Otherwise… you could consider to change your FDQN… But IDK if this will solve your issue.
Moreover… having a “public/real” FDQN could help you to have a validated SSL certificate for your hostname.

1 Like

You may use identities for Sogo itself. They are in mail preferences, IMAP accounts, edit your account.

Local domains with Sogo, ActiveSync and Outlook are not working, see Sogo and Outlook locale Domains - #7 by mark_nl

From the documentation:

When choosing a domain for Active Directory use an internal domain which is a subdomain of the external domain

1 Like