Wrong dns IPV6 entry with a NS7.3 fresh Install

@dev_team I found a bug that I can reproduce it two times with the ISO NS7.3 on a fresh Install.

when I installed the server, I decided to set a static IP in anaconda. After the installation I can find this

[root@tutu ~]# config show dns
dns=configuration
    NameServers=8.8.8.8,fe80::fa1a:67ff:fe51:677c%eth0

Of course the server cannot resolve dns name, only the ping through IP is valid. The direct consequence is that your server has no internet :slight_smile:

Could you paste here the contents of?

/root/anaconda-ks.cfg

Network information

network --bootproto=static --device=eth0 --gateway=192.168.12.1 --ip=192.168.12.71 --nameserver=8.8.8.8 --netmask=255.255.255.0 --ipv6=auto --activate
network --hostname=tutu.tutu.com

I see --ipv6=auto: this explains the ipv6 DNS address, if your network has a dhcp server or some other autoconfig mechanism.

dhcp yes, but no ipv6…normally :slight_smile:

I see a similar content of /root/anaconda-ks.cfg
If I recall correctly, I haven’t seen any option to activate or deactivate ip6. It is just enabled by default. IMO something that can potentially give an extra way in for the badguys…

Anaconda is sometimes difficult to understand, but I don’t think this is a bug. Next time you install with interactive, review the network settings before pressing “Done” :wink:

Will do. For what I saw, only the dns entry 8.8.8.8 was set

Mmh, that %eth0 looks weird… I’m not an ipv6 expert but seems really strange to see such token in our DB…

@stephdl could you investigate what is that IP? Where does it come from? What does it point to?

1 Like

new try with virtualbox instead of proxmox, the same but with another name

I did another eperience, Install with virtualbox, but in the NAT network (no bridge)

seems good, I don’t know why yet, but somewhere on my network, I have an IPV6 answer.

[root@leo lsd]# ping6 -c2 ff02::1%eno1
PING ff02::1%eno1(ff02::1%eno1) 56 data bytes
64 bytes from fe80::96de:80ff:febf:d656%eno1: icmp_seq=1 ttl=64 time=0.242 ms
64 bytes from fe80::1e6f:65ff:febe:f1ae%eno1: icmp_seq=1 ttl=64 time=0.271 ms (DUP!)
64 bytes from fe80::28c4:dfff:feca:6af3%eno1: icmp_seq=1 ttl=64 time=0.343 ms (DUP!)
64 bytes from fe80::3436:63ff:fe64:3161%eno1: icmp_seq=1 ttl=64 time=0.361 ms (DUP!)
64 bytes from fe80::3061:65ff:fe37:6136%eno1: icmp_seq=1 ttl=64 time=0.369 ms (DUP!)
64 bytes from fe80::3032:65ff:fe65:3032%eno1: icmp_seq=1 ttl=64 time=0.424 ms (DUP!)
64 bytes from fe80::3837:65ff:fe37:3963%eno1: icmp_seq=1 ttl=64 time=0.452 ms (DUP!)
64 bytes from fe80::fa1a:67ff:fe51:677c%eno1: icmp_seq=1 ttl=64 time=0.458 ms (DUP!)
64 bytes from fe80::3090:1bff:feaf:fe0a%eno1: icmp_seq=1 ttl=64 time=0.465 ms (DUP!)
64 bytes from fe80::a889:6dff:fe61:b633%eno1: icmp_seq=1 ttl=64 time=0.512 ms (DUP!)
64 bytes from fe80::4a51:b7ff:fe99:93fa%eno1: icmp_seq=1 ttl=64 time=48.7 ms (DUP!)
64 bytes from fe80::ee88:92ff:febd:8e4b%eno1: icmp_seq=1 ttl=64 time=49.1 ms (DUP!)
64 bytes from fe80::9ea0:d783:5e65:e095%eno1: icmp_seq=1 ttl=64 time=52.8 ms (DUP!)
64 bytes from fe80::ce07:e4ff:fe33:5a3a%eno1: icmp_seq=1 ttl=64 time=84.6 ms (DUP!)
64 bytes from fe80::96de:80ff:febf:d656%eno1: icmp_seq=2 ttl=64 time=0.247 ms

— ff02::1%eno1 ping statistics —
2 packets transmitted, 2 received, +13 duplicates, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 0.242/15.973/84.687/26.997 ms

I have an IPV6 dhcp server somewhere, still need to investigate

ok found it. I have no dhcp server with IPV6, I was sure of that, it is the IPv6 of my router

eth0      Link encap:Ethernet  HWaddr F8:1A:67:51:67:7C  
          inet6 addr: fe80::fa1a:67ff:fe51:677c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:213960 errors:0 dropped:0 overruns:0 frame:0
          TX packets:169085 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:211886797 (202.0 MiB)  TX bytes:84452425 (80.5 MiB)
          Interrupt:4 

What I discovered tonight it is that all servers (even NS6 and NS7) get an IPV6, but my router (openwrt) answers its ipv6 (however no activated dhcp server on IPV6). When I set the ipv6 settings of anaconda to ‘ignore’ (–noipv6), I have no problem of bad IPV6 dns entry.

does the --noipv6 can be tricked by kickstart as a default setting ?

1 Like

Ipv6 doesn’t need DHCP!

http://www.tcpipguide.com/free/t_IPv6AutoconfigurationandRenumbering.htm

1 Like

the question now is : does this issue is specific to my environment where I have plenty of servers and a (tricky openvz) router or it could be find in others LAN.

Only time will tell :wink:

1 Like