Wpad.dat misformed due to wrong $smb

webproxy
activedirectory

(Corentin Bertrand) #1

Hi all,

My wpad.dat contains PROXY [IPADDRESS]:3128

I just promoted him as domain controller.

in /etc/e-smith/templates/var/www/html/wpad.dat/90proxyDefault
at row 10 $smb{‘ServerRole’} is empty.
Here is what he contents:
service|DeadTime|10080|HomeAdmStatus|disabled|InheritOwner|no|NetbiosAliasList||ShareAdmStatus|disabled|TCPPorts|139,445|UseClientDriver|yes|UseCups|enabled|WinsServerIP||access|green|status|enabled

There is no ServerRole definition

The consequence is that I get the IP address instead of the hostname

In /etc/samba/smb.conf I’ve got security = ADS

Thanks


(Markus Neuberger) #2

Hi @InformatiqueOLLN,

welcome to Nethserver Community. This is a known bug:


(Corentin Bertrand) #3

Hi,
I’ve seen the bug you’ve linked, but I thought it was different.
I just added $adJoin = 1; after the test and it worked like a charm.
Thanks