Wordpress, or any CMS fails to work

I have been trying to upload a cms, specifically wordpress, but this applies to most. It uploads fine, then setting it up the site just looks awful, nothing loads right. I have php 7.1 installed as that is what literally everything is on now, not sure why 5 is still in nethserver. Mariadb required for wp is 10, we are on 5.5. I know there is a wordpress addon in the repo but why can’t I upload files and have them work? Never had any issues with my lamp stack through any other distro. I am just curious if anyone else has tried this, or how nethserver handles the LAMP stack. Apache seems fine, ive imported all my databases from mysql to mariadb, but code just doesnt seem to run right. Appreciate the help, I am pulling out my hair, I can, if needed, do it all through command line and reinstall LAMP stack and php and maria, manually updating it to 10 but I do not know yet how nethserver handles it and do not want to break my gateway :smiley:

How did you install wordpress…from a rpm or a tar.gz

How did you upgrade php to 7 ?

The key of your issue is probably there

It’s a web server running standard lamp stack so I just uploaded the files to my root of the site. Php isn’t the issue, I can set versions per vhost, just curious what’s missing on the stack. WordPress loads it just is all text and no formatting. Never had a distro do that, if it’s a deficiency in the lamp stack I can install. Wp requires apache, a db, and Php. We have all that which is why I’m so confused.

You’d answer to the questions that Steph made you

OK I downloaded the WordPress from the WordPress website as usual, unpacked the file, uploaded through Filezilla through ftp, I am using default Php on the site currently, Php test page checks out normally, Php is working properly, I hope that answers the question more thoroughly. Moved from Debian where I had to upload the files and it worked, I wasn’t aware Linux differed this much. Well it doesn’t, I will try and reinstall the lamp stack tonight from terminal tonight I guess. I’ve done this hundreds of times and this is just handling code really weird.

please, answer to this question, thank you
(sorry Steph, it’s not a question for you, of course)

I used the plugin, it lets you switch between versions per vhost. I am using default though to rule out issues

NS is not a plain Centos, so before you start to mess with your server (and likely break it) read the documentation

Oh I have :slight_smile:

so, again, before messing up your server, ask here for help giving us all the details…

nothing interesting in /var/log/httpd/error_log ???

when you install wordpress from epel you need at least :


if you are using the default php of my module, then you are running php54

Yes I am using 5 now, tried it with 7 but that didn’t help or hurt so I went back to 5. I’ll go back to 7 when I get it all figured out, for security. Thanks stephdl, I’ll check and see if those modules are installed or enabled. If not I’ll install them ez pz, and if that’s the issue great! I do appreciate it.

I don’t know if it is related, but wordpress stores the url in its database; and if after you change the url by apache (for example, the virtualhost or the alias name) then wordpress displays its content without css, a bit like you are talking.

it is a known issue

Wow your’e right. It isnt loading css…I believe it might be a .htaccess issue but for some reason the server will not respect htaccess files. Its all text so I assume it is a css issue, so somewhere along the line httpd is telling it a wrong location? Or a bad redirect? Ive made sure all the required modules are installed. Im going to reboot because as all of us in IT say…Have you tried turning it off and back on again? :smiley:

Well i am just having the worst time getting this to work. I figured out what the issue was, the site is calling insecure js and css scripts and blocking it. So ssl was forced through the vhost, and when i turn it off and just use http, it works. So its an ssl issue? I used letsencrypt on my previous debian install and it worked flawlessly, I did it through terminal. If I install clean wordpress, enable ssl in the vhost and set https as the site url in wordpress settings it fails to load entirely, stating “to many redirects from the server”, and I have to go into the database and edit the site url back to http. Never had that issue before, super weird. Any thoughts? Something that may or may not be related, .htaccess files are sometimes respected and sometimes not.

RewriteEngine On RewriteBase / RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L]

this guy is the default wordpress htaccess, which makes the site load the nethserver page, telling me to add an index.html which is already in the directory. Very odd. nothing is behaving like the httpd I know, but then again, I am still trying to figure out how nethserver tweaks it :slight_smile: its all a learning experience for me on centos. Thanks again!

debian is a nice toy (I use it also), centos is a nice tool, do you see a difference :slight_smile:


For me the Issue you have is you started the installation by a http access, then you used https. Wordpress is really sensible to the url you used the first time during the installation.

I’m not a big fan on .htaccess because I have a full access to the server and its configuration, sometime I have Issue also when I redirect to ssl or with reverse proxy

the wordpress apache configuration is there

i do start with https/ssl, and my browser block insecure content because it calls http content from https…I did go through the database and replace all http links with https but back to the issue of an error page stating to many redirections from the server. Also again im not using the nethserver wordpress, im using the files download straight from the wordpress.org website, as that should work just as well if i have the webserver working correctly.

Edit: Sick burn on debian :sunglasses: thats low I love ubuntu… :blush:

Edit2: Just for kicks I installed wordpress from the official nethserver repo…same thing exactly. INstalled through terminal, tried to install and exact same issue, i get all my js and css blocked because im using https.

Edit3: Fixed it. Had to change all the hardcoded http in the backend code to “//”, now I get no content errors in the dev console of chrome and ssl is working perfectly. We may need to pin this as this is an issue effecting ALL wordpress plus ssl users.

For nethserver-wordpress I force the https directly before the mysql database creation, so you cannot have this Issue