Wordpress Cannot be updated in the admin panel


(Francesco) #1

Hello.
Coinciding with the latest system updates on nethserver 7 wordpress does not update the version and asks for a localhost connection in ftp. I did some tests and it seems to be a problem of permissions on php.
Thanks to those who can tell me how to solve the problem.
02

54


(Markus Neuberger) #2

Hello @france,

yes, it seems like file permissions are not ok.

  1. I assume you setup wordpress in a virtual host.
    You may check permissions/ownership with ls -l /var/lib/nethserver/vhost/YOURVHOST and set apache as owner with chown -R apache: /var/lib/nethserver/vhost/YOURVHOST

  2. You may try enable FTP and enter the credentials just for the update.

Source:

https://codex.wordpress.org/Upgrading_WordPress#File_Ownership


(Francesco) #3

Hi, no I have installed wordpress from the repository.


(Stéphane de Labrusse) #4

rpm -qa | grep wordpress
please return


(Francesco) #5

wordpress-4.9.4-1.el7.noarch
nethserver-wordpress-1.1.5-1.ns7.sdl.noarch


(Stéphane de Labrusse) #6

ok it is normal, the update is disabled for the core because you installed it by rpm. You must wait that epel release the new version

eventually in /usr/share/wordpress/wp-config.php

you have this option define('AUTOMATIC_UPDATER_DISABLED', true);

you can try to trick, surely you miss the good permission for apache in /usr/share/wordpress/

In fact you should wait :smiley:


(Francesco) #7

Thank you for your immediate reply.
Now I understood why it was not updated. I’m not in a hurry.
:smiley:


(Stéphane de Labrusse) #8

nethserver is a vibrant community :slight_smile: