Windows login to Samba share (using Active Directory accounts provider)

NethServer Version: 7.6.1810 (final)
Module: Shared Folders

This is a fresh install of NethServer.

I have 2 network cards, one green (IP Address and one Red (IP Address

NethServer is doing the DHCP and DNS Resolution with the Gateway IP address being a NetGear router (IP Address

I have some port forwarding on the NetGear router setup to direct certain ports to the Red interface on NethServer.

The name of the server is

2 Issuesa and the 2nd issue is more critical than the first.:

  1. The server name does not appear in the Windows 10 Network Neighbourhood. This not much of an issue, however I am unable to browse to \server while \ does work.
  2. When trying to log into the Shared folders, I use the username as\james with the password which I know is correct as I can log using SSH, yet the login is denied.

The share in question has the Owning group set do domain users which I am a member of with Allow write permission to owning group and Allow read permission to everyone and Browseable is ticked while Guest access is set to none as we don’t want anyone else to Read or Write to the share.

On the ACL tab for the share, I am listed and I have both the Read and Write option ticked.

Its been 2-3 years since I had to set this up from scratch last so I can’t remember what I did last time to fix this.

Nothing is showing up in messages or secure logs for the failure.

Any recommendations of how to fix this?

Red and green on same subnet?

sigh yes unfortunately.

Well the good news is that my config is all correct and all I had to do was restart the server and everything worked.

No idea why…

… bad. At least, IMHO.
Routing capabilities could flip a lot with this setup.
Would you explain why you have to keep this subnets?

Yeah I know - completely bad.

Unfortunately its down to:

  1. Lack of the Netgear router to do multiple private subnets
  2. CentOS to properly implement UPnP

I had to agree with centos. I don’t like Upnp. Anyway… I am happy you solved the issues.

Having GREEN and RED on the same subnet and having the netgear router the same IP address as the GREEN interface of NethServer is a WRONG configuration. whatever you try, first fix this. It is not going to work if you leave it this way.
RED and GREEN must be on different subnets. (wonder how you managed to get the same subnet on red and green accepted by NethServer config anyway)

If the netgear only does 1 subnet, you can opt for double NAT. Have RED on the same subnet as the netgear router, and the GREEN subnet on any other subnet.