Windows 10 not showing Servers/Shares in Network browser

NethServer Version: NethServer release 7.7.1908 (final)

I hate to post another “file shares” topic but I’ve searched and all the ones previously posted doesn’t quite match my situation. I have a simple Ubuntu Server 18.04 as my AD controller. I use Nethserver for my files shares, printer shares, VPN.

Ubuntu 18.04 = AD
Nethserver = File Server

Windows 10 clients (1909) does not show any of the Servers and/or shares when clicking on Network. However, typing in the server name in the URI list the shares with no problem. I’m not sure what to look at first.

I have group policies that are redirecting authenticated users’ “Documents” over to the Nethserver. But that is all. I’m don’t have a clue why Windows 10 clients cannot browse using Network. I don’t have any other versions of Windows to test other than Windows 10.

If anyone have suggestions or can steer me in the right directions, much is appreciated. So far all is working out well except for the file share browser. Thanks for your time.

Could this be the problem:

Did you join NethServer to the samba4 domain?

Thanks for the reply.

My Nethserver is joined to the samba4 domain. Unfortunately the link wouldn’t apply to me. This behavior for me is using authenticated users to the domain. All appears to be setup correctly. My Nethserver being a member can see and administer all my domain users. When creating groups and shares with ACLs, my nethserver correctly queries and list joined users/administrator accounts, etc…Really a head scratcher. Also, I should add that I’ve tried to set “protocol=SMB3” from other suggestions as well. This did not work either.

I also noticed these lines in my smb.conf…Would these setting make a difference?

#Alias NETBIOS names, used to provide access to Samba via multiple hostnames

netbios aliases =

; WINS setup (other server)
wins server =
remote announce =
remote browse sync =

More research has shown that this is a deliberate function of Windows 10 PCs due to the security flaws of SMB1 protocols which ultimately led to the exploits of Wannacry virus. The suggested solution is to simply type the \hostname\share into the address bar which is what is working anyway. I’ll just have to create group policies to map necessary shares.

Sorry to waste your precious time.


SMB 1.0 can be installed via PowerShell or via graphic, adding windows Components. But as stated in different placese, SMB 1.0 is too old to be a safe choice.

Absolutely yes, but I had a similar problem or windows did not see the PCs and the network, after changing these parameters, the browsing worked. Maybe this can be a backgroung to start investigating the problem and at the moment put the PC into production …