Wierd problem of not able to reach "some" web sites

NethServer Version: 7.9.2009
Module: PPPoE, Routing


Background: I am using a local internet service provider. They put an industrial WiFi device on top of my house roof and I can get on the internet using this device. After a while I got problem reaching certain web sites. Some of the web sites were not browse able on my computer or on any computer in the house. Service provider suggested I connect a laptop directly to the network cable coming from that industrial WiFi. When I do that, I see all web sites are fine. I can browse problematic web sites just fine. At that time, I thought problem was my hardware router. So, I removed that router and started to use NethServer as a router in a VM because that seemingly solved my problem back then.

I just started to have exact same problem with NethServer. These started a couple days ago as far as I can tell. I did not pay attention until today.

I tried to connect the network cable from NethServer VM to a Laptop and once I connect using PPPoE on that Laptop, I could again browse all of these web sites that are problematic.

One example is: www.delphiturkiye.com

This web site can be reached if I use a Laptop not with NethServer. Below is a traceroute output run on NethServer

[root@neth ~]# traceroute www.delphiturkiye.com
traceroute to www.delphiturkiye.com (, 30 hops max, 60 byte packets
 1 (  18.680 ms  18.644 ms  18.629 ms
 2 (  31.726 ms  31.717 ms  31.704 ms
 3 (  41.689 ms  41.670 ms  41.663 ms
 4 (  52.266 ms  52.247 ms  52.235 ms
 5  ae3-17-xcr1.ise.cw.net (  52.216 ms  52.201 ms  52.187 ms
 6  ae29-xcr1.sof.cw.net (  60.167 ms  44.858 ms  104.924 ms
 7  ae-11.r01.sofibu01.bg.bb.gin.ntt.net (  51.283 ms  97.220 ms  97.180 ms
 8  ae-3.r20.mlanit02.it.bb.gin.ntt.net (  123.012 ms  95.824 ms ae-6.r21.vienat02.at.bb.gin.ntt.net (  95.786 ms
 9  ae-2.r00.vienat02.at.bb.gin.ntt.net (  95.777 ms  93.507 ms ae-1.r00.mlanit02.it.bb.gin.ntt.net (  95.746 ms
10 (  95.737 ms (  103.716 ms (  103.697 ms
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *
[root@neth ~]# 

I installed lynx text browser on NethServer to see if it will be able to display the page. All I see on lynx is below screen:

Which I take is that NethServer is actually cannot receive data from that web page for a reason I do not know. Screen stays like this for a very long time. I did not have the patience to wait and see if it ever ends.

I have all updates installed in my system. No update is available that can be installed as of today. Everything is default on NethServer except my PPPoE setup for the WAN interface.

I know there are people who know way better network internals than me here. So I am asking:

  • Why Windows 10 Pro PPPoE can browse above web site and NethServer PPPoE cannot using identical network cable?
  • How can I fix it?

I do hope this is something that could be fixed after all.

Thanks & Regards,



As I read it, you need to use PPPoE on that cable to get Internet.
Did you also have to use PPPoE on the wireless connection?

If you reboot the NethServer, do you have connection again to all websites?

This could help troubleshooting the problem…

My 2 cents

If you refer “Wireless connection” as the industrial WiFi device connection. That is I do not know. I do not know what protocol they use or any other details. I am provided a network cable coming from that WiFi and all I do is to plug that cable to a computer/router and setup PPPoE and put username/password I am provided.

It does not help rebooting NethServer VM or bare metal OS that VM (FreeNAS) is running in. Problem continue after reboot. Problem continue after shutdown, wait 10-20 seconds and start again.


OK, I think I understand…

Have you tested eg if using a Win10 Notebook (left on overnight) - does the connection start dropping?

My 2 cents


I have a system running 7/24 which require internet access and I am receiving reports for that system if it has a service break downs. No problems reported so far. I can say connection is not dropping on NethServer.

Moreover, there were no such problems for months. After I switched to NethServer as router, I did not face no problem until a couple days ago.

Problem is only certain web sites cannot be accessed. Looking it in detail (lynx text browser picture in my initial post), I cannot receive web service response.

Could you please enumerate at least 10-15 sites that cannot be accessed?
Also, are these sites https capable?
Are you using content filtering/proxy on your NethServer?

Below is what I could identify so far. If more added to the list, I can update that list.


www.hepsiburada.com (I get another error page displayed for this one saying it cannot reach main server)

Above, first URL is plain HTTP to my knowledge and second (and probably all others) should be HTTPS.

NethServer is default installation in my case. I did not manually turn on any content filtering.