Whatsapp not sending and receiving straight away

NethServer Version: 7.7.1908
Module: Firewall

Hi All,

I have a number of sites running NETHSERVER and they all have a similar complaint. A number of users battle with sending and receiving whatsapps using the app on their phones. They will send a message and it will take a very long time to send (if at all) unless they switch off wifi and use their data.

In the squid access log I am picking up entries like this:

1578289035.725 30103 TAG_NONE_ABORTED/000 0 POST http://c.whatsapp.net/chat - HIER_NONE/- -

Can anybody give me an idea as to why the firewall/proxy/content filter would be stopping throughput of WhatsApp?

Thanks in advance.

NethServer Version: 7.7.1908 (final)


I have the same problem that sending Whatsapp messages take a very long time (or even don’t get sent) with just one phone in the lan: a Xiaomi Mi A1, which is running Android One; when using mobile data there is no problem, so it must be the combination of this phone and NethServer. Other phones in the lan (all Android 8 / 9 of other brands) don’t have this problem.

As I thought it has to do with this phone or Android One, I didn’t investigate further and adviced the user to use mobile data for Whatsapp. I still hope there will come a solution.

It does not seem to matter what version of android on my side.

In terms of comparing, do you have “Block access to web sites using ip address” switch on in your content filter? I am wondering if WhatsApp tries to access its servers via IP?

Just some ideas:
Did you try to whitelist whatsapp.com and whatsapp.net in contentfilter?
Also it could be that clamav is interfering. Try to temporarely disable it.
Also ndpi could block whatsapp. Here we’re are blocking whatsapp (and facebook etc.) in our network with ndpi rules. Any rules related to that?

Thanks Flatspin,

I have added those two domains to the whitelist and disabled the antivirus. (not running NDPI at all the sites, but getting similar results so it is not that)

I am going to get the users to test at the various sites.

Thanks for the suggestions.


I’ve noticed the same with Squid and after a bit of digging I saw that WhatsApp needs facebook. So try adding facebook.com to your whitelist. It helpded and I am only registered here because I was looking for a solution and have found one that works.

Kind regards

That’s bad. On several levels…

1 Like

As suggested by Flatspin, it is one of the following: (I am still troubleshooting)

Switch off Block Access to web sites using IP Addresses
Switch off Antivirus
Put WhatsApp.com and WhatsApp.net in the whitelist.

I am now going to re-enable the VP and see if the problem comes back.

Will update once testing is done.

It was a solution that didn’t last very long. Still having troubles connectiong to WhatsApp :frowning: