WebTop5: multiple issues for HTML editor for mailcard

NethServer Version : 7.6.1810 (updated yesterday)
Module : nethserver-webtop5 1.2.19-1.ns7

Trying modifying a mailcard within Webtop5, I encountered a lot of issues (see below).

Expected results: Every changes made within mailcard editing window (with the included WYSIWYG interface or with the “Source code” view) should be saved inside the mailcard.

Steps to reproduce :
1 - Install NS
2 - Install mailserver and Webtop5 applications
3 - Try to modify the mailcards with the following instructions:

  1. When the editor appears, put the focus inside the text block and insert some text by keyboard. It should have the same behaviour also if you select all the text and replace it or if you use placeholders. Preview is fine, mailcard is created when you push OK button, but the mailcard is completely different from what you inputed:
# cat /var/lib/nethserver/webtop/domains/NethServer/com.sonicle.webtop.mail/models/mailcard_test.lcl.html 

I have also tried to logoff-login again after modifying the signature, no avail.

  1. Repeating the same operation as the point before but, at the end of the editing, interact with the “Font” or “Font size” dropdown menu, the mailcard will be saved with the modified content (but not always formatting);

  2. Modifying the signature using the “Source code” button on the signature interface doesn’t work either; only if you interact, at the end of text modifications, with the “Font” or “Font size” dropdown, some of the code modifications you do is retained (but also I found not all ones: Arial text has been changed inside source code (but just the text), then changed the font to Times New Roman; text is modified in the signature, but font family is again Arial).


@lucag may be interested in this. Please insult @giacomo if you preferred this to be on the Enterprise part :slight_smile:

1 Like

Let’s call the whole @webtop_team here :slight_smile:

Hi @syntaxerrormmm :smiley:

I tried to replicate internally the problem you reported but I couldn’t :thinking:

Can you tell me the type of browser and the version you’re using?
Could it be some particular extension that intervenes in the editor phase? Can you possibly try to disable them?

1 Like

Google Chrome stable version 77.0.3865.75 (official build, 64 bit) from AUR repos on Manjaro Linux (which really should just repackage the .deb version).

I took the time to review my extensions and excluded them all from the incognito mode; the results are that I can reproduce any of the issues described even without any extensions enabled.

You are perfectly right, I have tried with another browser (Firefox 69.0 64bit for Manjaro within Private Session, to ensure I have any extensions disabled) and I can’t reproduce any of the described issues.

So it seems to be down to a browser compatibility problem.
I plan to make some other tests with other Chrome versions and other OSes, just to complete the scenario.

1 Like