Webtop5 does not start after migration

Hi, everybody,
today I migrated from one server to a newer one.

AD works correctly
Roundcube I can access and see the message

Webtop gives the following error
all 2 servers have version 7.8 installed

HTTP Status 404 – Not Found

Type Status Report
Message /webtop/login
Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.

Apache Tomcat/8.5.51

I already did an uninstall and reinstall, I saw that some permissions in the webtop folders were not 755 the user was correct

I found these errors in the webtop logs
/var/log/webtop/webtop.log

Caused by: org.postgresql.util.PSQLException: FATAL: password authentication failed for user “sonicle”
2020-06-13 21:35:50 [ERROR] c.s.w.c.a.s.WTContainerSessionListener - WebTopApp not available
java.lang.IllegalStateException: WebTop environment is not correctly loaded. Please see log files for more details.
2020-06-13 21:35:50 [WARN ] c.s.w.c.a.s.WTContainerSessionListener - WebTopApp is null
2020-06-13 21:35:50 [WARN ] c.s.w.c.a.s.WTContainerSessionListener - SessionManager is null

Could you check postgres is running properly?

systemctl status postgresql

If it’s not running try to start with:

systemctl start postgresql

If yes please try to login with:

su - postgres -c "psql webtop5"

If you can login you should be able to start webtop.

systemctl start tomcat8@webtop

Please post here you results :slight_smile:

2 Likes

systemctl status postgresql
● postgresql.service - PostgreSQL database server
Loaded: loaded (/usr/lib/systemd/system/postgresql.service; enabled; vendor preset: disabled)
Active: active (running) since Sun 2020-06-14 13:56:22 CEST; 8min ago
Process: 1626 ExecStart=/usr/bin/pg_ctl start -D {PGDATA} -s -o -p {PGPORT} -w -t 300 (code=exited, status=0/SUCCESS)
Process: 1519 ExecStartPre=/usr/bin/postgresql-check-db-dir ${PGDATA} (code=exited, status=0/SUCCESS)
CGroup: /system.slice/postgresql.service
├─1652 /usr/bin/postgres -D /var/lib/pgsql/data -p 5432
├─2757 postgres: logger process
├─2854 postgres: checkpointer process
├─2855 postgres: writer process
├─2856 postgres: wal writer process
├─2857 postgres: autovacuum launcher process
└─2858 postgres: stats collector process
Jun 14 13:56:17 srvup.--------.it systemd[1]: Starting PostgreSQL database server…
Jun 14 13:56:22 srvup.--------.it systemd[1]: Started PostgreSQL database server.

[root@srvup ~]# su - postgres -c “psql webtop5”
psql (9.2.24)
Type “help” for help.

webtop5=# help
webtop5=#

if I try to ask for help, nothing happens.
thanks for your reply

What is the output of systemctl start tomcat8@webtop?

1 Like

[root@srvup ~]# systemctl start tomcat8@webtop
[root@srvup ~]#
nothing relevant, it’s also running

[root@srvup ~]# systemctl status tomcat8@webtop
● tomcat8@webtop.service - Apache Tomcat 8 Web Application Container
Loaded: loaded (/usr/lib/systemd/system/tomcat8@.service; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/tomcat8@.service.d
└─webtop.conf
Active: active (running) since Sun 2020-06-14 14:37:51 CEST; 14min ago
Main PID: 1459 (java)
CGroup: /system.slice/system-tomcat8.slice/tomcat8@webtop.service
└─1459 /usr/lib/jvm/jre-1.8.0/bin/java -Djava.util.logging.config.file=/var/lib/tomcats/webtop/conf/logging.properties -Djava.u […]

Jun 14 14:37:51 srvup.------.it systemd[1]: Started Apache Tomcat 8 Web Application Container.

And if you go to webtop login page?

same :frowning:

Can you explain exactly how you proceeded with this migration?
Did you perform the steps of a disater recovery?

Was webtop already installed on this target server before this migration?

previous with 7.8:
a) backup configuration in the backup section (button run now)
b) Restic data backup 1st backup in new disk (run now button)

new server
0) installation NS 7.8
a) run yum update -y
b) I uploaded the configuration file in the backup section and I asssigned green and red zone. it took a long time, I waited until the notification at the top right disappeared, I reloaded the page every 2-3 minutes.
c) I proceeded with the restoration of the data, always in the backup section
e) I didn’t have a lot of data about 20GB
f) AD domain users ok, all mail in the boxes was present
g) not seeing webtop working, I installed roundcube and saw that I could access the mail and see all the messages.

I had an idea what if I tried to reload the configuration file?

Ok @loryaegis:thinking:
try to align the sonicle user password on postgresql like this:

  1. get the correct password from here:
    cat /var/lib/nethserver/secrets/webtop5

  2. change the password on postgres with this command:
    su - postgres -c "psql -qAt -c \"alter user sonicle with password 'XXXXXXXXXX'\""

  3. launches this event:
    signal-event nethserver-webtop5-update

Let me know if you solve :wink:

3 Likes

This is magic! It works!!!
thank you very much!

1 Like

I would like to make a report, one of my addresses has many messages, I noticed that up to 130,000 messages in one box (in my case INBOX) is displayed the list. I think the limit is between 130,000 and 189,000 messages. If the limit is exceeded, messages are not displayed in the list.
I learned to move older messages to other folders. I just wanted to make a report.

Nice job @lucag! Always on top!

1 Like

I’m glad I was helpful ! :+1:
You could set the topic to solved as shown here :wink:

1 Like

I do not know this type of limit … can you better explain what happens ?

Yes, of course, although I’d do better in Italian.
the INBOX box had about 189,000 messages.
I usually use Thunderbird which downloads messages into POP3 but I don’t have them deleted.
One day I needed to access messages via webtop, but the message list was not uploaded.
I had to create an “archive 2019” folder and move some of the messages via IMAP.
When I got to 130,000, webtop showed me the list of messages. I just can’t assess whether the maximum limit for viewing on webtop is 140,000 or 150,000 because I wasn’t always checking.
Mine is curiosity :smiley:

I think you gave a such interesting info to dev team of Webtop…
Which browser you were using? How much ram the system had?

you want me to open a new thread?
maybe that’s more accurate since you’re not referring to this problem.
yes, it is a Lenovo ThinkSystem ST550 Intel® Xeon® Silver 4110 CPU @ 2.10GHz x 16 with 32Gb of ram, disks are SAS. at the time I made “the error” to format it in BTRFS, RAID managed via hardware. Unlike many I like BTRFS. unfortunately redhat will no longer support BTRFS.

There are currently 129,695 messages in INBOX.

I tried both Safari and Firefox. The version was NS 7.7

Besides, now that I see it, it’s an enterprise version, not a community version…

Beg your pardon… the configuration reported seems to me like more a Workstation than a server. Is this your client computer or your NethServer hardware?

no no è un server