WebTop - Shared Folder - Error copying emails over quota limit error

Hello @webtop_team @lucag,

I’ve created an account for our secretary to use that is our mail account for client correspondence. We have other mail accounts used by our bookkeeper and our owners and they have access to the secretary’s account as a shared mail account from their accounts.

I’ve discovered our owners and others who have access to the secretary mail account under shared are not allowed to copy mail from their accounts to the secretary’s email. The secretary’s email Inbox has many folders and we want to keep some mail in this one common place. But when we try and move mail to the folder in the secretary’s Inbox we receive an error like the one below.


I’ve confirmed that the secretary has enough room on her email. I’ve also confirmed that the secretary can move mail from her own Inbox into the folders under her Inbox.

What is the reason for this error and what can i do to fix it? Is this a permissions issue? I’ve checked and all people who have access to the secretary’s email account have full control.

Thank you.

Hi Charles,
I remember encountering this error in case the user receiving the share has the mailbox quota exceeded…

In practice, if the user with whom you access the webtop (e.g. user1) has the mailbox quota close to the maximum limit, when performing an operation at the IMAP level on the shared account received (e.g. secretary) the value of the quota that is increased is that of the user (user1) and not that of the shared account, this is because on dovecot the login is always that of “user1” and not the “secretary”.

Can you check if in your case the user has the quota close to the maximum limit?

1 Like

Hello @lucag,

Thanks very much for this reply. I’ve dug further into my problem. I do see where the problem is now and it is related to mail size quota Here’s the scoop:

My setup is a little different than normal. I have two employees who don’t need to use their own email accounts but use a generic account. You have helped me set this up previously so that when these users login they only see the generic email accounts and not their own. This is working very well for us.

So for example I have Sally our secretary with a domain account of:
and we have our general inbox with a domain account of:

FYI.comapny.local is not our mail domain. We use company.ca for our email. So in the Email module of Nethserver I create a new address and select my domain user as the destination. So for Sally and info domain users I create the following:

sally@company.ca and I set the destination of sally@company.local
info@company.ca and I set the destination of info@company.local.

This allows me to login to Webtop with either info or sally accounts.

Next I setup in my info webtop account a sharing of identity to allow Sally to manage this account.
Then in the Sally Account in Settings > Mail > Advanced I enter into alternate root folder: Shared/info@company.local

This allows me to login to Sally’s account and all she see is the info email account.

This is where the trouble begins…

In Netherver > Email > Mailboxes, I set a quota for the info mailbox of 10 GB. We save a lot of emails in the general inbox.
In Nethserver > Email > Mailboxes I set the quota for Sally to be only 1 GB since she will never receive emails to her address.

The problem I encountered though is Webtop wouldn’t allow Sally to do anything with the Info account to delete or move mail without receiving a over quota error message. The solution was to increase Sally’s quota to also be 10 GB. Now Sally does not receive over quota email errors and she can do her job.

Here is my ask (finally)…

For Sally increasing her quota to 10 GB is no big deal since she will never receive email. But I also share our info@swaslab.local account with other users who will see the info email account under their Shared folder. These users will also need to move or delete email from the Info mailbox. But if their quotas are below the size of the info account they also receive an over quota error message. So I’ve had to increase all my users who access the info mailbox to have much larger quota sizes than I would like to give them.

Is there a way to make this work so that I don’t have to increase all my users mailbox sizes?

Sorry for the long detailed response.

Thank you.

1 Like

Hi Charles,
I have carefully read all the description of your current configuration…

Unfortunately, I don’t think we can do better with dovecot shares.
The quota follows the user you log in with even if they must operate in a shared account.

You can try to search if there is any particular configuration on dovecot to get what you are looking for starting here: https://wiki.dovecot.org/Quota/Configuration

I’m sorry but this thing comes a little out of my skills :grimacing:


1 Like

Hello @lucag,

I completely understand and I realize my request was maybe unique. For many years our secretary and accountant logged in with an info@company.ca and accounting@company.ca email accounts. Webtop has afforded me the possibility to create user domain accounts and using Identity sharing and ‘Alternate Root Folder’ settings.

Thanks very much for taking the time to read my question. I will do some more searching but it’s not the end of the world with the way I’ve set things up now.


1 Like