Webtop Schedule invitation not sent to other users

webtop5

(Kristian Reukauff) #1

Hi, I have a fresh installation (for testing) of Nethserver. I installed all updates, Instant messaging, NextCloud and Webtop modules.
I configured Webtop for Instant messaging, NextCloud and set default user settings for German environment. I created two test users and logged in as both users in different browsers (Edge and Chrome).
When I create a schedule and add additional users (here: the second testuser), the other user don’t get an invitation. Is this a bug or is this how it should work?

See the attached screenshot how I added invited the second user.image


(Luca Gasparini) #2

Hi @Hunv,
the missed invitation is due to the lack of the flag enabled alongside the guest:
enable_invite

If you want to enable by default the sending for each guest you need to activate this option (right click on the calendar -> change calendar):
enable_invite_2

Try again and let me know :wink:


(Kristian Reukauff) #3

Yes… layer 8 problem :wink:
I just missed that checkbox. I will enable it by default because I think that makes more sense.

Is it possible to change this global?


(Luca Gasparini) #4

we can ask @gabriele_bulfon and @matteo.albinola if it is possible to do it through a query directly on the db


(Luca Gasparini) #5

To change massively on db this value (from false to true) for all the calendars currently present:

su - postgres -c "psql webtop5"
webtop5=# update calendar.calendars set invitation='t';

If you want to do it only for some calendar you can see the calendars on the db as follows:

webtop5=# select calendar_id,user_id,name,invitation from calendar.calendars;

then run the “update” query by selecting with “where” the calendar to be updated

Currently there is no global settings to modify the defualt of this setting, for this reason, every new calendar created will have again the invitation value set to ‘f’.