Webtop Not Working with Vhost in MS Edge browser Version 106.0.1370.52 (Official build) (64-bit)

I am running latest up to date version of nethserver, as at 29/10/2022 and
MS edge Version 106.0.1370.52 (Official build) (64-bit) running on windows 11. 22h2

I am unable to acces webtop, which has a subdomain enabled onto it.
Upon inspection, i am getting the error non js module files

the same webpage loads corrctly on vivaldi browser
the same page also loads correctly on firefox

Edge is not updated and i cannot replicate; nethserver-webtop5-1.8.9-1.ns7.noarch and webtop5-1.5.7-1.ns7.noarch as packages.

I tested this fully updated installation and Edge 107.0.1418.24 (still not latest) and i can access using Admin user and some “normal” user without issues.

I used https://my.site.tld/webtop to access.

try setting https://webtop.site.tld

I cannot. VirtualHost was not setup and the hostname is not public. Using the notation I suggested is working on Edge?
Edit: edit the topic name.

using https://hostname.site.tld/webtop actually works even for me, its the virtualhost config that does not.

Thanks for editing the topic title.
The rendering engine should be shared between Edge and Chrome (blink), therefore might be 3 options:

  • Edge needs to be updated because has issues
  • There might be a bug (waiting for other tests with infos)
  • one way or another, something into the network environment is not working as expected… PTR? reverse? Namesolving into the browser (which should not be an issue but whatever)

If you’re trying to access to https://my.site.tld can you see the expected website of Nethserver?

yes, that works with no issue, and every other system on the server too works ok. including NC

If you want a different check you can send me privately the public hostname…

With Edge 107.0.1418.26 (latest available here) I were able to detect that browser change address from https://webmail.site.tld/ to https://webmail.site.tld/webtop.
Loading is pretty slow, but might be due to distance and not the fastest connection ever from here to the destination.
The same address, used in firefox, allowed faster load.
Both browser in Incognito/Private mode.

ok, so using edge, you are also getting the same error on your end.

Well… no.

Slow, but worked. Try to update Edge.

aftr updating the browser, it worked, so it appears to be an issue with that version of edge