Webtop - How can I remove some email accounts from showing up in the addressbook suggested list when composing an email

Hello,

@webtop_team or @lucag

Our Nethserver is our domain server and our mail/webtop server. The domain is called company.local. But our email address is company.ca. So for each user I created in Nethserver a user@company.local is created and I create an address for each user and link it to our company.ca. For example, I create a domain user called:
sally@company.local
In Email I create a sally@@company.ca and I link it to sally@company.ca.

Each person in our office then uses their email of company.ca for all email correspondence.

I then have two users who don’t need personal email addresses and instead they use generic email address:
accounting@company.ca
info@company.ca

To support these generic accounts I share the identify of these generic accounts with the users that use them. For each user I set in Settings > Identities > Automatic identities from sharing. So when these users login they login with their user id but the email account they only see is their generic account. So using the users above, Sally uses our info@company.ca account and other webtop users should only send email to info@company.ca and not to Sally because Sally can’t see her own personal email as she only sees and uses the info@company.ca email account.

I hope this is making sense. Up to here this all working well for us.

The problem we have discovered with our users is in Webtop when they are writing an email, they type in Sally and our users see in the suggested contacts two Sally’s:
sally@company.local
info@company.ca

This is throwing people off and they are sending emails to sally@company.local and obviously Sally is not receiving them.

How can I remove Sally@company.local from our address book so our users won’t see it?

Thank you.

Don’t know if it is exactly what you want but here is a similar case:

Hi Charles,

If I understand your request correctly, to solve it you just need to change the email addresses of the main identities of the users you do not use for the email (those with @ company.local).

You can do it massively from the admin panel with a multiple selection of these users, then right click and select “Bulk update email domain”:

Immagine

You will also find everything described here: https://nethserver.docs.nethesis.it/en/master/webtop5.html#user-settings-management :wink:

At the next login in the automatic search you will be shown the new email address set.

Let me know if this is what you were looking for

BR

3 Likes

Hello @lucag ,

I don’t understand what this ‘Bulk Update email domain’ does, but it does appear to have fixed my issue.

Thanks very much!

1 Like