Webtop extended search slow and different results to quick search

I have to problem with the extended webtop search:

  1. The extended search is MUCH slower than the quick search. The quick search gives results almost immedatly, whereas the extended search for just the subject (not full text) takes much longer.

  2. Even then, the results are not the same. Extended often says: “no results” but quick search shows lots of them.

Can you help with this?


Hello @m.traeumner and @carsten,
a bug was recently found on advanced search: https://issues.sonicle.com/browse/WT-1012

The effect is that the search at some point loops without continuing to deliver results. Seems slow it’s actually blocked.

If your advanced search gets to the bottom and provides different results from the quick search it might just depend on the search key used.

On dovecot the FTS plugin is active by default and this causes the need to use only search keywords with whole and not partial words to have consistent results from the search.


1 Like

Release 5.12.4 is ready to be tested which contains the fix for the advanced search :wink:

To install from testing:
yum update --enablerepo=nethserver-testing webtop5 nethserver-webtop5

@carsten can you let us know the outcome of the test on your installation?
Thank you.

1 Like

It works! Thanks.
However, the problem, that the results are not sortable, is still open.

1 Like

It worked in one test, unfortunately it doesn’t work now. Same problem. Are they any logs, which can help finding the problem?

With the latest update from I installed it seems to work now.


If it isn’t stopping to work, please mark this topic as solved.