WebTop AES SyncProblem

NethServer Version: 7.7.1908
Module: WebTop

I facing an issue where WebTop ActiveSync is not working correctly on an iPad with IPadOS 13.4 (also with 13.x). Nethserver is fully patched.

I set up the ActiveSync Account on the iPad. Everything get´s synced (calendar, contacts, Tasks) and mail.

But since then only mails are pushed correctly. Calendar events, tasks and contacts only get synced when I change something in the corresponding app on the iPad (e.g. deleting/changing or adding an event).

These are the webtop Settings:

webtop=configuration
ActiveSync=enabled
ActiveSyncLegacyIds=enabled
ActiveSyncLog=ERROR
DavServerLog=ERROR
DavServerUrl=
Debug=false
DefaultLocale=en_US
DefaultTimezone=Etc/UTC
DefaultToolbarIconsSize=medium
MaxMemory=1024
MinMemory=512
PbxProvider=
PbxProviderNethvoiceWebrestUrl=
PublicUrl=
RemoteCalendarAutosync=enabled
RemoteCalendarAutosyncOnlywhenonline=disabled
RemoteCategoryAutosync=enabled
RemoteCategoryAutosyncOnlywhenonline=disabled

Does anybody have a similar Problem?

Does NethServer has a public FDQN?
Does NethServer issue a certificate for SSL connection?
Is UTC your actual timezone?

I would not suggest to use ActiveSync for mails, and use an imap client instead.
Try configure the AS account with only calendar and contacts active.

Gabriele

yes Nethserver has a FDQN with a valid letsencrypt cert.
The timezone was wrong but after adjusting the timezone the problem still persists…

I removed the account and added it again after adjusting the timezone and with only contacts and calendar.

Still the same problem…

also strange: Now when I check the webtop settings
„ActiveSync=enabled“ is not present in the settings anymore.

Even after „config setprop webtop ActiveSync enabled“ and „ signal-event nethserver-webtop5-update„
it is not shown in the settings…

Hi @schweidj,

evidently the nethserver-webtop5 package was not updated before :wink:

The prop that allowed you to disable ActiveSync has already been removed from several versions, it is now always enabled.
You just have to pay attention to this: http://docs.nethserver.org/en/v7/webtop5.html#webtop-vs-sogo

1 Like

Hi @lucag

thank you Luca. I was Aware of the webtop-sogo conflict.
I tried adding a contact and an event today and it synced successfully at once.

I don´t know why. Maybe I just had to wait some time after changing the timezone….

Thanks also @pike for the timezone hint

1 Like

Once is not enough! Try a to do more edits/adds into contacts and calendar.

Hi @pike

you are right, second try, same Problem. No sync….

I’ll wait your feedback tomorrow too, with some other tests :wink: