WebTop 5 needs testing

Yes, WebTop 4. But beside it, there is also Tomcat and other dependencies. Maybe some of them, as version, are not compatible with the version which came with WebTop 5.

But, I can roll back this exact same machine to before WebTop 4 was installed and the WebTop5 works.

If you need the emails, you can use Thunderbird or other Desktop Email client to download them by IMAP and after rollback and install WebTop 5, you can have them back.

Yes, I realize that, but I have everything else configured on my server, network shares, NextDrive, email aliases. It is just a test server, but I have setup a lot on it, and I would not want to just start over.

As is written here:


all basic functions works.

Yes, I want to try it on a live system, MY live system, with all my configuration setup for other apps, my LE cert etc. but I cannot uninstall WT4 and re-install WT5. Surely someone else has done this? No?

I think I read about that but I’m not sure.
Also, I think it was a recommendation to install WT 5 on a system without WT 4.


Found it!


( Note: WebTop 5 must conflicts with WebTop4.)

Ok, bummer, looks like I will be starting over from scratch.
I assume that when WT5 goes to release, there will be an upgrade path from WB4?

From Roadmap:


Publish always up to date source code
Basic developer and user documentation
Translations opened to external contributors using a public tool
Better mail client with improved Sieve filters, folder subscriptions
Migration path from WebTop 4 to WebTop 5

1 Like

Ha, thanks, I should learn to read better.
Maybe I will wait until there is an upgrade path.

But you already have a broken WebTop.
Or you will try to uninstall WT 5 and reinstall WT 4? Maybe will work.

Yes, but I run on a VM, I took a snapshot before trying the upgrade, and just rolled back. I will install a 2nd test VM and check out WT5, it’ll just be harder to test with noone using it.

@wbilger, what I’ve tried:

  1. Installed webtop4
  • removed webtop4 and some remnants
  • installed webtop 5

got the same error (but logs might tie it to a different source cause, logs were showing password authentication error and non-existent sonicle role). What worked in my case was to delete webtop databases and sonicle user from postgresql, and reinstalling webtop5. Don’t know if devs will recommend against it, as I’m removing more things than really needed.

WARNING - Don’t try this in production.
This is not an upgrade path, it ditches most of webtop config/data…(make backup/snapshot beforehand)

CASE 1 - With webtop4 installed, before installing webtop5:

#----removing webtop4----
yum remove \*webtop\*
rm -rf /var/lib/tomcat/webapps/webtop

#----removing webtop database and its user----
su - postgres
dropdb webtop
dropuser sonicle

#----optional: removing additional webtop4 remnants----
rm -rf /usr/share/webtop /etc/e-smith/events/nethserver-webtop4-update /etc/e-smith/templates/usr/share/webtop /etc/e-smith/templates/var/lib/tomcat/webapps/webtop /etc/e-smith/templates/etc/httpd/conf.d/webtop.conf /etc/httpd/conf.d/webtop.conf /var/lib/nethserver/secrets/webtop

#----installing webtop5----
yum --enablerepo=nethserver-testing install nethserver-webtop5

CASE 2 - If webtop4 was removed and webtop5 installed but accessing its webpage shows the error you mentioned earlier:

#----removing webtop databases and its user----
su - postgres
dropdb webtop
dropdb webtop5
dropuser sonicle

#----reinstalling webtop5----
yum --enablerepo=nethserver-testing reinstall nethserver-webtop5

There must be a better way to get rid of the error, till then…


Please follow @dnutan advice, since now I haven’t even tried to substitute WT4 with WT5 on the same machine.

Regarding the language pack, we will set the translations next week.

@gabriele_bulfon will open an issue regarding the cloud error. I hope to have all fixed next week

Tested ActiveSync as described here:



  • Regarding “Select “Complete” inside the “Synchronization” field”

Inside the “Syncronization” field will find only “Off”, “Read-Only”, “Full”.
You must select “Full”.
@giacomo :
Can you modify this documentation according to this tags?

  • Regarding “ActiveSync must be enabled for each users”

ActiveSync cannot be set for the entire Users group (Domains -> NethServer -> Groups -> Users)? At least in the final version?


1 Like

cc: @giacomo


How I tested:

  • I removed added authorizations from each user.
  • Tested from CLI for each user and I don’t have in html page “GET not supported”.
  • I have set “Authorizations” for entire Users group.
  • Tested from CLI for each user and I have in html page “GET not supported”.


Can anybody test to see if really works?
At least other 3 guys?


no change in behaviour - what else I can try now?

Please try this:

Maybe is something wrong with the packages and this could fix.

no, not the solution, and now - even more worse - I’ve to do shopping with my family :wink:

1 Like

I’m already on my way … :joy:

have to stop now, but what’s this?

ah, now I’ve my calendar :smiley: - changed Theme!

A post was split to a new topic: [NFR] Mail: receipt button

That means that you solved?

This worked, perfect, thanks!