Webtop 5 issues


#1

Hi all.

Haven’t posted for a while but I have a few issues since upgrading to Webtop 5. I had a bit of a search and can’t find if any of these issues have been seen or reported yet.

The worst one I have found (along with my complaining staff) is when creating a new email (or replying/forwarding) and using “html text” formatting, right clicking in the body presents you with table insertion/editing options only. No copy/paste, spellcheck, etc. I tried with both firefox and chrome with the same result.

I generally use firefox (our staff all do) and the next few issues are when using firefox. I’ve got the latest FF version and have cleared all cookies, cache, etc.

  • FF occasionally crashes when you are just moving your mouse or clicking a section in webtop, offering to restore the tab and is fine for a while after that. I cannot pinpoint a reason why.
  • Sometimes logging in, the url changes with “/push” added on the end (i.e. server/webtop/push), you have to delete /push and the page then loads properly.
  • The first time you print an email nothing happens and webtop is busy, if you stop the page loading further, the system print dialog box appears.
  • When printing emails, only the first one prints. If you choose a different email and click print, the first one prints again. (This doesn’t happen in chrome where the browser simple printing dialog comes up and shows a preview and other print options).

I’m going to run my own webtop session on chrome for a few days to see if it behaves better.

Has anyone seen any of these issues or can replicate them?


#2

Another Firefox issue. When forwarding an email with attachment/s, the “X” icon to remove attachments is not showing so they cannot be removed.

I tried a fresh install of FF today to make sure it wasn’t old settings causing issues and all of the problems above still occur.

Moved all our users to Chrome now and Webtop behaves much better. The annoying issue is still the “insert table, edit cell” dialog when right clicking in new email body. I have found that CTRL+C / CTRL+V works for copy/paste in that situation as a workaround for now.


(gabriele_bulfon) #3

Hi, I have added the Firefox bug issue here : https://redmine.sonicle.com/issues/259

About the editor menu, you also can CTRL+right-click to access the browser menu.
We will discuss about the possibility of switching funcionality (leave right-click for browser menu, use CTRL+right-click for tables menu).

Thanks,
Gabriele


#4

Thanks Gabriele

I personally think it would be better switching functionality. Another option would remove the CTRL+right-click option and incorporate the “table” options as a sub-menu of the usual copy/paste right- click menu.

Using WT5 the last few days, I also noticed a few minor things that could be tidied up.

  • English mouse hover tips on the toolbar icons across the top: “Move to folder” tip shows java variable; “Multi-search” tip show java variable.
  • Right-click on folders or emails English mouse hover tips: Many showing java variable. I think these ones could be removed altogether as the text in the menus is self explanatory anyway.
  • Right-click on email: English “Move/Copy messagges”, should be messages (one g); “Reimposta colonne”, I think should be “Reset columns”.

If I can help tidy these things up, let me know how and I will.


(gabriele_bulfon) #5

AFAIK, there’s no way to integrate the table menu to the browser menu: that is entirely an html5 rendering, while browser menu is it’s own system menu.
Also, the reverse, it’s not very easy to integrate a custom copy/paste menu inside javascript driven actions, because copy/paste actions are controlled by the browser to be user intended actions, calling javascript functions for copy/paste is mostly blocked by all browsers (unless specific requests to allow these actions are taken).

Thanks for the translation issues.

Gabriele


#6

No worries Gabriele, I was just throwing ideas around from a usability point of view.

I appreciate the detailed explanation.


(Michael Kicks) #7

Maybe it’s the wrong place, but there’s a question that it needs a little answer:
is there a “browser compatibility list” for Webtop?

I am using Windows 10 as main interface, and trying to access to webtop… i am able to interact with admin user only if I use Chrome.
Firefox Quantum (58 beta) and Waterfox (a fork of Firefox 56) do not allow me to enter to admin options.
Both “'zilla” browser do not have any Java plugin, but as far as i know also Chrome do not support NPAPI plugin anymore.
JRE 1.8.0.150 installed on system.


(Markus Neuberger) #8

I am using Firefox Quantum 57.0.4 with Windows 10 and Webtop admin works.

java version “1.8.0_151”


(Michael Kicks) #9

Java installed is x64 just like browsers, @mrmarkuz?


(Markus Neuberger) #11

I have both:


(gabriele_bulfon) #12

We’re not aware of any issue on firefox, on any platform.

In these cases, a good choice to help us would be to open the browser console (F12) and give us back a trace of any errors appearing there during the problem.

Gabriele


(Giacomo Sanchietti) #13

I think it will be added to the new documentation.
Of course we will explicitly support mainline browsers :wink:

It’s a very good starting point, please feel free to open up a new topic for each issue! @lucag will be glad to summarize and report to the official WebTop bug tracker!


(Michael Kicks) #14

I was misleaded by Chrome (64bit only) working with only Java 1.8.0.181 32 bit installed; I don’t know why but it worked. Integrated plugin? Sincerely, i won’t investigate on that.
These statements from Oracle remains
https://www.java.com/en/download/help/firefox_java.xml

But after installing Java 64bit, keep not working the admin page.