WebTop 5 Contacts not syncing


(Rocco Brand) #1

Hi Guys

I am struggling with getting contacts to Sync on devices ie: Outlook, Android, IOS.

The emails, sending/receiving and calendars are syncing 100%.

Has anyone else experienced an issue like this? How can I fix it?

Thank you.


(Giacomo Sanchietti) #2

Please, start reading the zpush log and let’s see if we can find the culprit.

Take a look here for the paths: https://github.com/NethServer/nethserver-webtop5/blob/master/README.rst#troubleshooting


(Luca Gasparini) #3

Hi @RoccoB,
synchronization through EAS with WebTop 5 is fully supported only for mobile devices and I recommend you use it only for calendars and address books (also shared see here).

I advise you to configure the email always and only in IMAP (both on mobile devices and desktop clients) is more stable and more reliable :wink:

See also the manual here: http://docs.nethserver.org/en/latest/webtop5.html#device-synchronization-with-activesync-eas


(Rocco Brand) #4

Hi Giacomo

Thank you, I will follow the link and let you know how it goes :slight_smile:


(Rocco Brand) #5

Hi Luca

Thank you, I will check that and let you know how it goes :slight_smile:


(Rocco Brand) #6

Hi Giacomo,

Please note that I have checked the zpush logs and cannot see any errors relating to contact sync or sync not working. I also noticed that the time zone was incorrect on the server, so I have updated that to our correct time zone as per the document: http://docs.nethserver.org/en/v7/webtop5.html#troubleshooting

Please also see attached image of how the contacts are setup on webtop.

Thank you for all the help so far.


(Rocco Brand) #7

Hi Giacomo,

Have you been able to look further into my query?

Looking forward to your reply.


(Giacomo Sanchietti) #8

Sorry but I don’t know much on Webtop internals. I’m calling help from @lucag and @gabriele_bulfon


(Rocco Brand) #9

Thank you for all the help :slight_smile:


(Rocco Brand) #10

Hi Giacomo

Please see the below screenshot, Could this be the problem? I see that the Sync is blank.

image


(Luca Gasparini) #11

Hi @RoccoB
are you confusing your options :wink:

The ones you showed in your screenshot refer to the ability to synchronize shared contacts (see here) or remote address books (see here).

Synchronization of a personal directory is enabled by choosing “Edit category” (default is enabled).

Honestly it is strange that you can not synchronize with EAS this phone book. Have you tried with different devices?
Do you get an error on the device when it tries to sync?


(Rocco Brand) #12

Hi Luca

I followed the following steps:
"Synchronization of a personal directory is enabled by choosing “Edit category” (default is enabled)."
I set it to “Active”image but I am still not seeing the contacts on my cellphone or outlook on my PC. I just want to Sync normal Webtop contacts.

Thank you for all the help so far :slight_smile: