Webtop 5 calendar sync problem

bug

(Bill ) #1

When syncing an android phone to a webtop 5 calendar on nethserver there is a 4 hour difference in one direction only. If I add an event in web top it works properly when my phone syncs to it. But if I add an event in my phone calendar the start time will be 4 hours later in webtop.


(Michael Kicks) #2

Which is your time zone?
Are the phone and the server configured in the same one?


(Bill ) #3

server and phone are both USA Eastern timezone.


(Giacomo Sanchietti) #4

Please consider that you have to set the timezone in 3 different places:

  • the system (you already did it)
  • PHP:
config setprop DateTimezone US/Eastern
signal-event nethserver-php-update

  • WebTop:
config setprop webtop DefaultTimezone EST
signal-event nethserver-webtop5-update

Timezones are a nightmare :smiley:
If this works well, we can update the doc.


(Bill ) #5

Ran all 4 commands, they all completed without error. Problem still exists.
Re-booted server, problem still the same.


(Giacomo Sanchietti) #6

I’m out of ideas right now.

@webtop_team can you help here?


(Michael Kicks) #7

@happnatious1 I stay in Italy CET, Daylight Saving Time is used… is the same for your timezone?
@giacomo am i right if i assume that the clock server should be GMT?


(Bill ) #8

Yes, we have daylight savings time, clocks change by 1 hour.


(Giacomo Sanchietti) #9

I think you should be free to set server clock as you wish.


(Bill ) #10

there is a z-push log on my nethserver that is off by 4 hours. its currently 9:42

22/06/2017 13:42:44 [ 2058] [ERROR] [bill@domain.com] LoopDetection->ProcessLoopDetectionPreviousConnectionFailed(): Command ‘FolderCreate’ at 22/06/2017 12:52:15 with pid ‘2156’ terminated unexpectedly or is still running.
22/06/2017 13:42:44 [ 2058] [ERROR] [bill@domain.com] Please check your logs for this PID and errors like PHP-Fatals or Apache segmentation faults and report your results to the Z-Push dev team.


(Bill ) #11

I set the default timezone in /usr/share/webtop/z-push/config.php to America/New_York but still same problem.


(Michael Kicks) #12

And i also would like to do the same thing, but most linux distros sets the computer clock to GMT and calculate time/date by the time zone you set.
So…
Which is CentOS/NethServer approach on this?


(Bill ) #13

It looks to me like z-push is using UTC in one direction and EDT in the other. Changing config.php has no effect with either UTC or EDT. My RTC on vmware server is set to UTC. Later when I can shut down all my VMs I’ll change my RTC to EDT and test again.


(Bill ) #14

So now when I run timedatectl my RTC is set to EDT but syncing calendar events from my phone to webtop still uses UTC. I guess I’ll switch to SOGO next and see if there is still a problem.


(Bill ) #15

So I installed sogo and removed webtop5 and everything is working perfectly. Looks like Webtop5 isn’t ready for general consumption.


(Giacomo Sanchietti) #16

Sorry to hear this.

Come on @webtop_team can we still try to investigate the issue?


(gabriele_bulfon) #17

I bet it’s too late to check wt5 settings, as it’s been uninstalled now…
Anyway, other than the default TZ for webtop, users can setup their own TZ on the settings menu.
The user timezone is setup on first access by copying the default value above.
So, what was the TZ for the user? Maybe the default TZ was wrong for webtop, and users were created with that wrong default value? In this case, changing the default value later, did not update already created user’s TZ.

Gabriele


(Bill ) #18

Users time zone was set to EDT.


(gabriele_bulfon) #19

Can you check the content of /etc/adjtime ?


(Bill ) #20

contents of /etc/adjtime

0.0 0 0.0
0
LOCAL