WebTop 2FA sending 5 digit code instead of 6

NethServer Version: Nethserver 7
Module: Webtop

I have setup 2FA for one of the user Nethserver/Webtop user. When trying to login, Webtop is sending the code through email. Problem is, it is sending 5 digit code instead of 6. Suffice to say the user can no longer log into the webtop GUI. The login prompt keep saying to enter 6 digit code.

Anybody had this issue?

1 Like

Summoning @gabriele_bulfon and @lucag

1 Like

Hi @wahmed,
I can’t replicate your problem :thinking:

Can you verify that you have an updated version of Webtop?
Write me the result of this command: rpm -q webtop5

I did some test. Sometimes it happens, but I can login.

Ecco il tuo codice: 76065

I think you’ll need to verify code length in generation and also when code is not 6 char long in login form (because I can login also with 5 char code)…

I can’t always replicate.
The version is the latest in testing.

1 Like

Tried to resend the code several times by keep trying to login through GUI prompt. None of the 5 digit code worked for me. However after trying dozen times it did generate a 6 digit code and user was able to login.
Looks like the work around for now is to keep trying to login.