Webserver ns8 error when installing Piwigo server selfhosted

Hello everyone , after creating a db of my interest and copying the installation files of a selfhoted server to ns8 , then http://virtualhostns8.internal.lan/myapp , the installation procedure starts but reports me an error :sneezing_face:

Array ( [0] => No such file or directory )

Probably and to be attributed to the program, but I wanted to be sure if the error is perhaps generated by some missing permission or otherwise on the parameters of the virtualhost (webserver section). I left php83 and access only http .

Screenshot 2024-04-15 alle 10.52.07

Ì think you need to enter values for connecting to the DB like database name, user and password.
Instead of localhost you may also try the IP of the node holding the mariadb app or

There are others getting a similar error:


1 Like


Cia I had already tried …

Here it is:

Array ( [0] => Connection refused )

Setting the DB Host to the IP address of NS8 and adding the right port worked for me.

The port can be found in the mariadb settings:

Piwigo setup:

I created user and db with phpmyadmin.


Wait Wait … but did you enter the 20130?
Is it your door or does it refer to some containers?
i tried :sleepy:
Array ( [0] => Access denied for user ‘piwigo’@‘’ (using password: NO) )

Yes, check the screenshot.


It’s the external mariadb port. You need to enable it in the mariadb app settings.

You need to allow db user piwigo to login to the real IP.
It seems you just allowed it for

Then I could become rubber !! I would never have gotten there! So that’s the door to the instance?

Edit Privileges: User account ‘piwigo’@‘%’
@% is for any origin .

1 Like

Did you enter a password?

yes i create password in phpmyadmin for user piwigo

I meant did you enter it in the piwigo setup page?

Done ! I pulled away the password and it works.

But the fact that an instance needs to be inserted in the installation, in which reference guide is it written? Surely it was I who did not read, but if not so it is difficult to understand that it is necessary to specify the instance of the container.

Anyway thanks Maek, I owe a beer! :beers:

1 Like

Sorry on holidays

Localhost means linux socket in the mariadb world would means internal tobthe container so not possible

So you could use the external ipv4 or the internal (vpn) ipv4 address and the specific external port of mariadb