Web Proxy Transparent / Http and Https Block


(Jose G Jimenez S ) #1

Good Morning Community

I need the support of you to this situation configuration:

I set the proxy web as transparent and have activated blocking http and https

but when I surf the internet http blocks with the message in red, but the https just says it can not connect to that domain.

and if I activate the transparent option ssl https blocking me and gives me access to http.

I hope you can guide me to solve this.


Profile for web content filter
(Filippo Carletti) #2

I think that the option to block http and https is to be used when the proxy is set to manual or authenticated. When proxy is trasparent, port blocking is irrelevant.
If the proxy is set to Transparent SSL, transparent on http is implicit.


(Jose G Jimenez S ) #3

Ok,

Is there any way that https and http are blocked from transparent mode?

SSL transparent, open all https and blocked all https within the filter, but I do not open the http.


(Filippo Carletti) #4

In transparent mode, port 80 and 443 are implicitly blocked.


(Jose G Jimenez S ) #5

will attach some pictures:

I think I’m doing well, but I do not understand why not https blocks that are in the filter


(Jose "Martin" Abeleira. AKA Marto) #6

Did you tried to manually add the facebook address in the block list?


(Filippo Carletti) #7

The Social Networking category is the right choice, it contains facebook.com.
But you’re accessing faceboot using https and you’ve enabled the transparent proxy only for http (transparent). You have to select Transparent with SSL (or the other two options ans set the proxy in your browser).

Do you think that we could choose better labels for the various options?
The manual (http://docs.nethserver.org/en/latest/web_proxy.html) could be expanded?


(Jose G Jimenez S ) #8

tests’ll do tonight because in the company are laboring and do not want to remove the internet.

Thanks will comment.


(Jose G Jimenez S ) #9

@filippo_carletti @mabeleira

Make changes to the web proxy manually, http blocks all I want. https but just shows that you can not find the domain and not the show as blocked.

Is there any way to show the message block 403?

regards


(Filippo Carletti) #10

Not in ssl. I don’t have a link to explain the problem now.


(Tohid Tamboli) #11

i cant see social networking or other type of categories in web filter ?
So where is this option?