Web proxy disable via command line

NethServer Version: 7.3.1611 (final)
Module: 3.10.0-514.6.1.el7.x86-64

My server is set up as a AD DC with samba.
Been working like a charm with a few Windows 7 and two Windows 10 clients for a month.

In my ignorance I enabled the web proxy.

Now I can get as far as the -

“Congratulations, your NethServer installation is up and running!” page

But I can no longer access the server manager.

How can I disable the web proxy from the server command line as root?

Or work around this hick up?

Command to disable squid:

config setprop squid status disabled
signal-event nethserver-squid-update

I can’t guess how enabling proxy blocked access to server manager, could you please share more details about your setup?

config show squid

I think you try it with IP adress, this is blocked by default with proxy. Try it with


I used:

config setprop squid status disabled
signal-event nethserver-squid-update

‘config show squid’ reflects that the squid is disabled.

Then using IP:980 in chrome browser I now get:

Then I used:

config setprop squid status enabled
signal-event nethserver-squid-update

and tried:


which gave:

Good catch @m.traeumner
This accident leads me to think about revising the default web filter policy regarding blocking access to sites using ip addresses. I encountered some customers which have to access some websites using ip addresses.

1 Like

Please have a look at your ufdbguard conf, there should be an entry to block IP adresses, disable it.
Also you can try to modify your host file at your client wit the entry for your server. After that you could call it by name.

This topic is closed…
Thanks m.traeumner much appreciated
I added the entry ‘ signmaster.local nethserver-signmaster’ to the windows HOSTS file
and wha-la it gave me access to the server manager.

1 Like

You’re welcome.
Could you mark the topic as closed please.

But then we have lower security, what’s about a hint about it by enabling ufdbguard.

Or you could enable access to IP addresses only at the green interface