Web content filtering issue Nethserver 7.3

NethServer Version: NethServer release 7.3.1611 (Final)
Module: Squid Cache: Version 3.5.20 / ufdbgclient: 1.32.4

Web content filtering is not working well.

If I disable it, that all right, no filtering

If I enable it, I first have to do a ‘service squid stop’, then add some domains to blacklist, then click SUBMIT

If I just go on edit some domains then SUBMIT, nothing happens

At this point I deleted all custom domains from the ‘global blacklist’ and I still get blocked by ufdb on the ones I entered previously

If I restart ether squid or ufdb: same thing.

I checked /var/squidGuard/blacklists/custom/blacklist/domains => empty as expected

So I tried to rebuild db files running

ufdbConvertDB /var/squidGuard/blacklists/custom/

before restarting the whole thing with no more success :frowning:

I suspect there is something wrong the way ufdb manages domain db files

Hi Sebastien,
sorry for the late reply. I’d like to tag some content filtering experts here but I don’t know if they have some knowledge on 7
@MadCat @m_farlotta @vhinzsanchez @Freddy_Brignardello @acsel10 @jgjimenezs @Renan_Azedo_de_Olive @mansoor.tariq @cswain @Mario_Spang @telekomiker @Protagon_Antagon @Provolino72 @prostream @ssabbath @Walter_Schoenly

The database is built and reloaded automatically every time you change a blacklist, or on every list update. If it’s not your case, you may find some errors in the logs (/var/ufdbguard/logs/ufdbguardd.log).


Thanks folks.

Looks like it’s working just fine now. Did nothing though. Well, I suppose I needed to reboot or something…

A feature I’d be interested in (for further release): blacklists usually come categorized. It would be nice to be able to filter on these categories i.e. not only “adult” but also picking ‘dangerous material’, ‘astrology’, etc…