Web-Apps not accessible via local server name

NethServer Version: 7.3.1611
Module: webserver


I set up my server and several web-apps like phpmyadmin, round cube, nextcloud, wordpress and so on. They all were accessible via the the server name set in the admin-panel.

Today I created a new Virtualhost to make the server reachable via the internet and created a letsencrypt certificate. After this I cannot reach any of the web apps via the local-servername anymore.
I also get an error when restarting httpd:

AH01909: RSA certificate configured for nethserver7.joeshome.intranet:443 does NOT include an ID which matches the server name

Do you have any idea how I can fix this issue?


hy @schweidj,
read this

may help you

The Problem is not the Same. I cannot create a le-cert For both namens cause one host is the Public one reachable from the Internet and the Other one is the local servername set in servername pane in servermanager which is not resolvable from the Internet.
I cannot Access e.g. Phpmyadmin anymore cause its only Accessible from local Networks.

allow then it to the public side, but for a security concern it is not good

1 Like

Sorry but, allowing access to phpmyadmin for everyone outside is not an option.

When I issue curl -L -v -k https://servername/phpmyadmin from a host connected to the local network via vpn (a network not bridged and not created via nethserver but from a pfsense box) I get

403 Forbidden


You don't have permission to access /phpmyadmin on this server.

* Curl_http_done: called premature == 0

when I do this from the server itself everything works. I have disabled the firewall and selinux and added the network to the phpmyadmin.conf.
What else can restrict access to this site?


restart apache ?