VPN roadwarrior a LAN

Hello community,

I wanted to see how I could access from my VPN roadwarrior to the LAN of my network.
Currently my roadwarrior VPN is connecting but not accessing the LAN or pinging. If I check the “Route all client traffic through VPN” box, I can ping but if I deactivate it, I can’t.

Is there any way to access the LAN without checking this box “Route all client traffic through VPN”?

Is the VPN NethServer the gateway? If not, you need to add a static route on the gateway device.

“Push all static routes” should be enabled.

Yes, it is Nethserver’s roadwarrior VPN.
From what I was able to validate, if I enable the option of “Route all client traffic through VPN”, I consume the bandwidth of the company and the ideal is that if I work with VPN, only access the resources of the company but consume the width of band from my home.
For this reason, I asked if there was another way to do it, since if the company blocks social networks, when activating the vpn I also block social networks.

The static route would be: vpn network + nethserver’s green network + nethserver’s green interface?

OK, I think the issue is clear.

Do you use routed or bridged VPN? What’s your VPN network address?

Possible solutions are:

  • Enable "Push all static routes” in advanced options of roadwarrior settings on Nethserver.
  • If your Nethserver is not directly connected to www, meaning there’s a router in front of the Nethserver, you may need to configure a route (static route) on the router because the router does not know about the VPN network and drops the packets.

The static route should route the VPN network to the Nethserver.

1 Like

WAN eth0:
LAN eth1:

Nethserver is virtualized, all internet traffic is directed directly to the nethserver virtual machine


If I activate the vpn roadwarrior connects but I do not ping or access the LAN and I would like to do it without activating “Route all client traffic through VPN”

Enable "Push all static routes” in advanced options of roadwarrior settings on Nethserver: If I activate this option, I access the LAN through the VPN but it limits me to all the restrictions that the LAN has in the VPN.

1 Like

Steven, HI! could you fix it?