Vn7 beta1 - UK keyboard problem

NethServer release 7.2.1511 (beta1) - When installing Vn 7 alpha3 I installed the GB keyboard and made it the default. I’ve since updated the software and now have beta1, but I’ve found my keyboard layout is now the US layout, not the UK layout. Not sure when this happened, how do I change it back to the UK keyboard please ?


temp solution: loadkeys <keyboard-code>

loadkeys uk

More options: Changing keyboard layout

Thanks for the reply. The ‘loadkeys uk’ command appears to run Ok, but in hindsight that may not have been my problem. I’ve just changed the login password to one that has an ‘@’ symbol in it, which differs between UK and US keyboards. The login prompt only offers ‘English (United States)’, even after running ‘loadkeys uk’. That appears to be the problem I have :slight_smile:


You can change the keyboard layout during the interactive install.
After the installation, the system should not change the keyboard layout.

Of you need to make any persistent modification, use the localectl command:

Setting the locale to ‘en_GB.utf8’ using ssh access :

paul@DPC_001 ~ $ ssh root@
root@'s password: 
Last login: Wed Jul 13 15:04:42 2016 from

************ Welcome to NethServer ************

This is a NethServer installation. 

Before editing configuration files, be aware 
of the automatic events and templates system.

[root@nethserver ~]# localectl set-locale "LANG=en_GB.utf8"    
[root@nethserver ~]# localectl status
   System Locale: LANG=en_GB.utf8
       VC Keymap: gb
      X11 Layout: gb,us
     X11 Variant: ,
[root@nethserver ~]# 

…and re-booting doesn’t change the browser login page it still only offers ‘English (United States)’ and I have to use the ‘shift 2’ key to get the ‘@’ symbol in the password :frowning:

This also applies to the ssh password :frowning:
Not sure if this makes a difference, I’m running ns7 in a VirtualBox VM

The web browser login page has no english (uk) translation.

I think it’s an option that changed in vbox regarding the keyboard.
It’s like if you plugged in a new wrong keyboard in a physical system.

Ok thanks, I’ll change the password for now so I don’t get a problem.


Hi Paul :slight_smile:

the language selection on the web login page only affects how the web interface is displayed, not related to the keyboard. If the UI is accessed from the host computer you can check the latter has the correct keyboard settings, as sometimes weird things happen.