Virtual Machine won't run ISO

virtualization
v7
webvirtmgr

(quizhead) #1

Hi all,
I have a problem with the VM I installed.
I have downloaded the manager from the software manager and configured an instance.
I’ve uploaded an ISO of windows 10 which is working and connected it to the VM…
After all that the VM won’t start the ISO.
Any ideas ?


(Markus Neuberger) #2

Hello @quizhead,

here are some docs howto setup webvirtmgr:

https://wiki.nethserver.org/doku.php?id=ns_webvirtmgr

It should boot Windows 10 iso, I tried it:


(quizhead) #3

I followed the guide with no success.
Nethserver is on VMware if it helps.


(Markus Neuberger) #4

I tested with VMware too.

Are there errors in /var/log/libvirt/qemu/YOURVM.log?

Are there errors on boot screen of the VM?

Are the rights ok on your ISO storage?

[root@testserver ~]# ls -l /var/lib/libvirt/iso
total 3747216
-rw-r--r-- 1 qemu qemu  304087040 Mar  7 13:05 debian-9.3.0-amd64-netinst.iso

(quizhead) #6

In all the logs a certain message appear : CPU feature tsc_adjust not found
Maybe this is the problem - what does it means ?


(Markus Neuberger) #7

Did you use a default template for your vm? It seems like a CPU feature is not supported.

Your (virtual) CPU has to support virtualization, maybe you have to set it in your VMware guest settings.


(quizhead) #8

I used the templates and tried to look for an option to enable CPU virtualisation in the ESXi which with I’m working with, tried a few options but nothing worked.


(Markus Neuberger) #9

Which ESXi version do you use on which hardware?


(quizhead) #10

ESXi 6.5

hardware :
8 CPUs x Intel® Xeon® CPU E5504 @ 2.00GHz
23,99 GB RAM


(Dan) #11

I’m not sure if this is relevant to ESXi, but under bhyve on FreeBSD, nested virtualization isn’t supported without a 56xx-series CPU or higher. It would explain what you’re seeing.


(quizhead) #12

Thank you.
I guess it’s not supported.


(Rob Bosch) #13

I was about to mention nested virt might not be supported… :slight_smile:


(Alessio Fattorini) #14

Ehi Quizhead welcome here :slight_smile: did you happen to fix your problem?


(quizhead) #15

well…I guess that my CPU is not supported for visualization.
I’m working with ESXi and I didn’t find any solution to this with this system with is Linux as well by the way.
I will try to install the Nethserver directly on a server to test this.
If you have any idea about how to do it on ESXi, I’ll be glad to hear.


(Markus Neuberger) #16

I run ESXi 6.5 with a Nethserver VM and tried nested virtualization now and it works.

I got these feature warnings too but the VMs start and boot from ISO.

CPU feature arat not found
CPU feature tsc_adjust not found

You may try to use only 1 (v)CPU in your VM settings in webvirtmgr.

grafik


(Armin) #17

I can,t upload an ISO file - I pretty sure my rights aren’t ok. So they should be “-rw-r–r--” as you posted? And who should own the directory - what is qemu in your post?

edit: current rights:

drwxr-xr-x 2 administrator@fmhm.local root 6 Apr 20 13:16 /var/lib/libvirt/iso

Thanks a lot!


(Markus Neuberger) #18

The iso folder should be created by root so root would be the owner:

drwxr-xr-x 2 root root  82 Mar 19 23:23 iso