Vhost / nextcloud / mattermost

Hi there,

on a fresh install 7.6 I noticed:

  1. if nextcloud is installed from the sofware repository then the webserver package does not install automatically. While nextcloud works I had to manually fix sudo rights for apache user to be able to run occ commands in cron.

  2. given the web server package does not install with nethserver the virtual hosts package is not installed. Installing it afterwards seems to be a problem. Although I can create a vhost later there is no directory for the in /var/lib/nethserver/vhost/.

  3. I then installed mattermost. After enabling it and providing the vhost name no vhost is created. Manual creation of the vhost under “virtual hosts” does also not create a vhost folder. Can not access mattermost.
    Also tried without success:
    config setprop mattermost VirtualHost mattermost.abc.yy status enabled
    signal-event nethserver-mattermost-update

Do not know if this issue exists if web server and nextcloud / mattermost are installed at the same time or web server before netxtcloud / mattermost.

Is it a bug or did I miss anything?


@support_team Could somebody confirm this?

What, exactly, did you do here?


  1. Installed nethserver 7.6 in VM did some basic configuartion
  2. Installed Nextcloud Package from Software Center
  3. Logged on to Nextcloud as admin and checked Installation. Cron was enabled.
  4. Added various plugins.
  5. ssh into NH as root to check installation
  6. crontab -u apache -e to add according to the howto various tasks with the following command
  7. */15 * * * * sudo -u apache scl enable rh-php71 – php -dmemory_limit=512M /usr/share…
  8. checked mailbox
  9. found message that cronjob did not run since apache does not have sudo rights
  10. usermod -aG wheel apache
  11. no cron job errors since then, neither in mailbox nor in the log

Looking at the other errors/observations it looks like there is a dependency to the web server package (virtual hosts) so that those modules need to be installed prior nextcloud.

Hope this helps.

I tried to reproduce the issue. I notice that there is no web server package in 7.6 anymore when I install from 7.6 iso. I think the issue comes from - install with ISO 7.5 - upgrading to 7.6 and then install the other modules. This may be explains why I have issues in my production system which migrated to 7.5 to 7.6 although it was locked.

Let’s close this thread. I will try a clean install from ISO 7.6.

Since this is apache’s crontab, the sudo -u apache seems completely redundant. If that’s something that’s done by the nethserver-nextcloud package, it should probably be fixed.

AFAIK it isn’t.