Verylongdomain Name

domain
v7

(Gordon) #1

NethServer Version: 7.4
Module: sssd
I know this has been discussed in VeryLongDomainName but I have 2 systems where the hostname exceeds 15chr and is rejected by the Web interface.

Is there a solution to this as these 2 systems which have been registered for years and have 20 and 28 chrs?


(Davide Principi) #2

Sorry I don’t understand. The host name is different from the domain name. What page rejects them? What are you trying to do?


(Gordon) #3

@davidep
Sorry for the delay timezones and travelling.
We are trying to setup a system using the registered domain name which is >20 characters. Like myverylongdomainname.com.au but the entry on the server manager page for server name seems to be filtering to only 15. The ref to the closed thread seem to indicate the issue had been resolved or has it be reinstated due to other issues in the AD?
If we can not use the offical domain name can we get postfix to accept the emails?
TIA


(Markus Neuberger) #4

grafik

On server name page you can’t set a name longer than 15 chars.

I tried following but no success:

[root@testvm2 ~]# config set SystemName veeeeeeeeeeeeeeeeeeeeeeeeerylongname
[WARNING] configuration DB: SystemName is deprecated on ns7 and read-only!

(Davide Principi) #5

The error refers to the host name part, whilst @compsos says “domain”.

So the UI complains with a name like?

  host1.veeeeeeeeeeeeeeeeeeeeeerylongdomname.com.au

(Markus Neuberger) #6

I think it’s about hostname:

veeeeeeeeeeeeeeeeeeeeeerylonghostname.domain.com.au

I tested domainname and it’s allowed to be longer than 15 chars.


(Davide Principi) #7

Thank you for you verification!

The 15 chars limit is imposed by NetBIOS on the host name part. It does not affect the DNS domain name suffix, so you should have no problem if you apply your very long company DNS domain name to NethServer to receive email with Postfix.

Just set it as

host1.veeeeerylongcompanydomain.com.au

(Gordon) #8

Hi Davide
Sorry, I should have been clearer. On the web management page you can enter
the sytem name like mydomain.com.au but in these cases the mydomain is very
long and is rejected.
If it is possible to allow ectra characters or does that cause issues for
the AD setup? Or can we have email accepted for the long domain name and
use something shorter for the systemname?
The referenced thread wad on the same issue and looked llike it had been
solved in 7.2 but not allowed in 7.4.
Thanks.


(Davide Principi) #9

Sorry for the late response, @compsos

Ok “mydomain.com.au” is parsed as

  • mydomain, hostname
  • com.au, domain name

It produces an unexpected configuration!

NethServer expects something like hostname.mydomain.com.au.